Bug 141914 - Obsoletes fails if new package version isn't greater than obsoleted package version
Obsoletes fails if new package version isn't greater than obsoleted package v...
Status: CLOSED DUPLICATE of bug 142272
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-05 18:42 EST by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-26 11:38:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2004-12-05 18:42:46 EST
Description of problem:

file /usr/lib/ks-postinstall/postinstall.d/99syslog from install of
cisco-bsh-syslog-1.0-4 conflicts with file from package
ks-postinstall-syslog-bsh-1.0-4

However, cisco-bsh-syslog-1.0-4 contains this line:
Obsoletes: ks-postinstall-syslog-bsh

If "a" Obsoletes "b", then shouldn't b-1.37 get Obsoleted by a-1.20
???  This seems like a bug as Obsoletes is only making the names
equivalent, and leaving the version numbers to still content with each
other (which means the old package might not be Obsoleted).


Version-Release number of selected component (if applicable):

RHEL3 with rpm-4.2.1-4.4
Comment 1 Joshua Jensen 2005-01-20 11:55:46 EST
Ping
Comment 3 Joshua Jensen 2005-06-06 11:58:47 EDT
ping

Note You need to log in before you can comment on or make changes to this bug.