Bug 1419167 - pulp worker status on capsule field counts too many workers
Summary: pulp worker status on capsule field counts too many workers
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Capsule
Version: 6.2.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 18:39 UTC by Chris Duryee
Modified: 2019-08-12 14:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 18:02:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chris Duryee 2017-02-03 18:39:11 UTC
Description of problem:

The "workers" field on the capsule health status page reports all of the pulp workers, but this includes the resource manager and scheduler. Only the "reserved_resource_worker" workers actually process tasks, the other two are for scheduling.

This leads to confusion if the user shuts down all of the pulp workers on a capsule, since it appears that workers are still running.

NOTE: it is technically correct that the scheduler and resource manager are workers, but the page is still confusing :) Also, it's not possible to get the scheduler entry to disappear since if you shut it down, there's nothing available to remove the record.

Version-Release number of selected component (if applicable): 6.2.7



Steps to Reproduce:
1. view capsule health status
2. perform "service pulp_workers stop" on the capsule
3. refresh capsule health page

Actual results: two workers running

Expected results: zero workers running


Additional info:

Comment 6 Bryan Kearney 2018-09-04 18:02:51 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.