Bug 1419188 - The error description in oc describe pod is misleading
Summary: The error description in oc describe pod is misleading
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.5.0
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
: ---
Assignee: Derek Carr
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 20:34 UTC by Siva Reddy
Modified: 2019-07-03 17:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-03 17:57:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Siva Reddy 2017-02-03 20:34:50 UTC
Description of problem:
   The error description in oc describe is not pointing to the root cause of the problem and is misleading 

Version-Release number of selected component (if applicable):
openshift v3.5.0.9+e84be2b
kubernetes v1.5.2+43a9be4
etcd 3.1.0


How reproducible:
always

Steps to Reproduce:
1. create a pod where the volume is full
# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/xvda2       10G  9.9G   95M 100% /
devtmpfs        7.8G     0  7.8G   0% /dev
tmpfs           7.7G     0  7.7G   0% /dev/shm
tmpfs           7.7G  757M  6.9G  10% /run
tmpfs           7.7G     0  7.7G   0% /sys/fs/cgroup
tmpfs           1.6G     0  1.6G   0% /run/user/1000
tmpfs           1.6G     0  1.6G   0% /run/user/0

2.oc describe pod/<<pod-name>> and note the message
pod (uperf-sender-fz18f) failed to fit in any node
fit failure summary on nodes : CheckServiceAffinity (3), MatchNodeSelector (3)

Actual results:
The message points to check affinity and match node selector where as the node selector requirements are met.


Expected results:
   It would be nice if it can some how point to the fact that there is no space.

Comment 2 Greg Blomquist 2019-07-03 17:57:41 UTC
No progress in 2 years on a low severity bug.


Note You need to log in before you can comment on or make changes to this bug.