Bug 141919 - graphical installer reports fatal error probe_partition_for_geom() failed
graphical installer reports fatal error probe_partition_for_geom() failed
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-05 20:51 EST by Pierre Kerr
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Kerr 2004-12-05 20:51:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Installing Fedora Core 3, after booting from CD#1, I get as far as the
graphical screen asking for language and then see a message:
"assertion (sectors <= 63) at disk_dos.c:490 in function
probe_partition_for_geom() failed" then a smiliar one "assertion
(heads > 0) at disk_dos.c:485 in function probe_partition_for_geom()
failed" with a choice of ignore or quit.  Choosing ignore to the first
message then brings up the second.  Ignore the second and the
installer exits.  The final screen has:
"X server started successfully."
"Starting graphical installation..."
"Bug"

followed buy the two messages that were displayed while in the
graphical installation.

This computer has two drives.  The first is a 20 gig with Windows NT
4.0 and two NTFS partitiions of 7 and 13.  The second drive is a 6 gig
with a RedHat 9 installtion on it.  

The computer is a Pentium 266 with 256 meg ram.

Thanks in advance
Pierre Kerr


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start computer with Fedora install disk #1 in cdrom
2.Answer questions about language and keyboard type

Errors appear
    

Actual Results:  "assertion (sectors <= 63) at disk_dos.c:490 in
function probe_partition_for_geom() failed" 

then 

"assertion (heads > 0) at disk_dos.c:485 in function
probe_partition_for_geom() failed" 

with a choice of ignore or quit.  Choosing ignore to the first message
then brings up the second.  Ignore the second and the installer exits.  

Expected Results:  I believe the next screen might be the partioning
questions

Additional info:

I did a media check before my first attempt.  Media was good.

This computer has been running RedHat 9 without a problem for many months.
Comment 1 Jeremy Katz 2004-12-05 21:50:28 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.