Bug 1419232 - [dev-preview-stg] Dancer-ex/perl 5.20 quota limit error
Summary: [dev-preview-stg] Dancer-ex/perl 5.20 quota limit error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Abhishek Gupta
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-04 02:18 UTC by Chris Ryan
Modified: 2017-04-05 20:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-05 20:55:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chris Ryan 2017-02-04 02:18:28 UTC
Description of problem:
Permission denied error is noticed when deploying a dancer-ex quickstart

Error creating: pods "dancer-ex-1-" is forbidden: [minimum cpu usage per Pod is 29m, but request is 11m., minimum memory usage per Pod is 150Mi, but request is 62914560., minimum cpu usage per Container is 29m, but request is 11m., minimum memory usage per Container is 150Mi, but request is 60Mi.] 

Version-Release number of selected component (if applicable):
Online STG 3.4.1.2

How reproducible:


Steps to Reproduce:
1. Create a dancer-ex application
oc new-app openshift/perl:5.20~https://github.com/openshift/dancer-ex

2. Patch perl image to autoconfigure based on available memory
oc patch dc dancer-ex -p {"spec":{"template":{"spec":{"containers\":[
{"name":"dancer-ex","resources":{"limits":{"memory":"100Mi"}}}]}}}}
3. wait for the build to finish, wait for deploy

Actual results:
Error creating: pods "dancer-ex-1-" is forbidden: [minimum cpu usage per Pod is 29m, but request is 11m., minimum memory usage per Pod is 150Mi, but request is 62914560., minimum cpu usage per Container is 29m, but request is 11m., minimum memory usage per Container is 150Mi, but request is 60Mi.]

Expected results:
The pod is deployed

Additional info:

Comment 1 Ben Parees 2017-02-04 05:04:57 UTC
This doesn't sound like it has anything to do with the image or new-app.  new-app does not set any resource limits on the pods it creates.  I suspect your patched memory value of 100mi is simply too low (hence the error telling you it is too low) and is resulting in a too low cpu value also (I believe the cpu limit is calculated from the memory limit in online).

Assigning to Abhishek in case the online configuration was unintentionally changed, but i believe this is working as designed.

Comment 2 Abhishek Gupta 2017-02-06 15:44:46 UTC
The lowest memory limit that Online Developer Preview will accept is 256Mi. Since you specified a value lower than that, it was rejected by the validation. This is working as intended. 

Assigning to QE to update their test cases.

Comment 3 Chris Ryan 2017-02-06 20:08:57 UTC
Updated the memory values to the suggested amount, and the case passed. We will update the test case to reflect these new values. Thank you!


Note You need to log in before you can comment on or make changes to this bug.