Bug 1419233 - Resized overview page lost service-group info and group button on overview page
Summary: Resized overview page lost service-group info and group button on overview page
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: Jessica Forrester
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-04 02:21 UTC by XiaochuanWang
Modified: 2017-02-06 14:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 14:22:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
smaller sized window lost group serivce info and group button (35.44 KB, image/png)
2017-02-04 02:25 UTC, XiaochuanWang
no flags Details
the correct view of overview page when size is normal (54.61 KB, image/png)
2017-02-04 02:26 UTC, XiaochuanWang
no flags Details
normal sized overview has group button (61.60 KB, image/png)
2017-02-04 02:29 UTC, XiaochuanWang
no flags Details

Description XiaochuanWang 2017-02-04 02:21:17 UTC
Description of problem:
Create a new app. Go to overview and threre is "No grouped services." Resize browser the smaller the better, check the info which is lost.

Version-Release number of selected component (if applicable):
openshift v3.5.0.16+a26133a

How reproducible:
Always

Steps to Reproduce:
1. $ oc new-app --docker-image=aosqe/hello-openshift
2. Go to overview and check service group info "No grouped services." 
3. Resize browser the smaller the better, check it again

Actual results:
3. The info is missed, the button "Group Serive" button is lost, please check the screenshot

Expected results:
4. The info should be displayed well include the button "Group Serive"

Additional info:
This is not related to User-Agent, only depends on the size of browser.

Comment 1 XiaochuanWang 2017-02-04 02:25:35 UTC
Created attachment 1247634 [details]
smaller sized window lost group serivce info and group button

Comment 2 XiaochuanWang 2017-02-04 02:26:26 UTC
Created attachment 1247635 [details]
the correct view of overview page when size is normal

Comment 3 XiaochuanWang 2017-02-04 02:29:38 UTC
Created attachment 1247636 [details]
normal sized overview has group button

Comment 4 XiaochuanWang 2017-02-04 02:42:12 UTC
Group button will existed only with multiple services on normal size, but the group button can be replaced by the "chain" icon at the right side of the serivce when browser is resized smaller. 

So the bug for smaller window is: 1. Lost "No grouped services." 2. Group icon is not easy to find when there are multiple services.

Comment 5 Samuel Padgett 2017-02-06 14:22:45 UTC
This is working as intended. It is still possible to group service as you note using the link icon, so no functionality is lost.

We are currently reworking the overview, including how services are grouped.

https://trello.com/c/QxbqJsoK

This will not be an issue in the new design.


Note You need to log in before you can comment on or make changes to this bug.