Bug 141927 - Kernel 1014-FC4 balks at USB
Summary: Kernel 1014-FC4 balks at USB
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-06 05:38 UTC by Scott Talbot
Modified: 2015-01-04 22:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-14 17:32:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott Talbot 2004-12-06 05:38:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041114 Firefox/1.0

Description of problem:
Upon login, find that my USB memory is not mounted.  I am able to
mount it in the terminal, but udev didn't do it at boot like I am used to

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.1014_FC4

How reproducible:
Always

Steps to Reproduce:
1.Boot (or reboot) to kernel-2.6.9-1.1014_FC4 with USB device attached
2.login
3.
    

Actual Results:  see no icon for USB device

Expected Results:  find icon on screen

Additional info:

I noticed a line during startup that proc/bus/usb was not found in
/etc/fstab or /etc/mtab, however saw it there also when I booted older
kernels that do work.

Comment 1 Ralf Ertzinger 2004-12-07 21:58:50 UTC
Confirmed, 2.6.9-1.1014 and 1.1018 on PPC. The device is found, the
whole hotplug shebang runs, modules are loaded, just the fstab-sync
step mysteriously fails to show up.

Comment 2 Dave Jones 2004-12-08 04:43:40 UTC
david, is this is the 'hal needs updating to support scsi layer changes' bug
again?  Did hal get rebuilt for rawhide yet ?

Comment 3 Ralf Ertzinger 2004-12-08 09:30:05 UTC
The last version of hal seems to be 0.4.0-10, built October 28 2004.

JFI, 2.6.9-1.1009 works fine.

Comment 4 David Zeuthen 2004-12-10 21:53:35 UTC
I just built a new hal package for Rawhide that is be able to cope with the SCSI
midlayer changes. It will appear in Rawhide tomorrow, it can also be downloaded
from here

 http://people.redhat.com/davidz/hal-testing2/

Btw, this is already fixed in FC3 as an update.

Cheers,
David 

Comment 5 Scott Talbot 2004-12-14 17:32:24 UTC
Works now!  Thanks Dave


Note You need to log in before you can comment on or make changes to this bug.