Bug 1419282 - GDAL module library isn't loaded
Summary: GDAL module library isn't loaded
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: saga
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Volker Fröhlich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-04 20:00 UTC by Juan Pucheu
Modified: 2017-12-12 10:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 10:29:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Juan Pucheu 2017-02-04 20:00:08 UTC
Description of problem:
GDAL module is missing. Cannot import or export files using gdal. Other modules that depends on it also fails. 

Version-Release number of selected component (if applicable):
2.2.4

How reproducible:
always

Steps to Reproduce:
1.go to geoprocessing menu, and clic on "Load Tool Library"
2. select libio_gdal.so
3.

Actual results:
Message console, in "general" tab, displays 
"Load library: /usr/lib64/saga/libio_gdal.so...failed"

Expected results:
"Load library: /usr/lib64/saga/libio_gdal.so...okay"

Additional info:
I'm using F25, spanish localization

ldd libio_gdal.so reports 
linux-vdso.so.1 (0x00007ffda850e000)
libgdal.so.20 => /lib64/libgdal.so.20 (0x00007fc9a52f9000)
libsaga_api-2.2.4.so => /lib64/libsaga_api-2.2.4.so (0x00007fc9a4f7d000)
libgomp.so.1 => /lib64/libgomp.so.1 (0x00007fc9a4d4f000)
libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007fc9a49c7000)
libm.so.6 => /lib64/libm.so.6 (0x00007fc9a46be000)
libc.so.6 => /lib64/libc.so.6 (0x00007fc9a42f6000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fc9a40df000)
libarmadillo.so.7 => /lib64/libarmadillo.so.7 (0x00007fc9a3ed6000)
libpoppler.so.62 => /lib64/libpoppler.so.62 (0x00007fc9a3a3b000)
libjson-c.so.2 => /lib64/libjson-c.so.2 (0x00007fc9a3830000)
libfreexl.so.1 => /lib64/libfreexl.so.1 (0x00007fc9a3626000)
libgeos_c.so.1 => /lib64/libgeos_c.so.1 (0x00007fc9a33f5000)
libwebp.so.6 => /lib64/libwebp.so.6 (0x00007fc9a3194000)
libodbc.so.2 => /lib64/libodbc.so.2 (0x00007fc9a2f26000)
libodbcinst.so.2 => /lib64/libodbcinst.so.2 (0x00007fc9a2d11000)
libkmlbase.so.1 => /lib64/libkmlbase.so.1 (0x00007fc9a2af5000)
libkmldom.so.1 => /lib64/libkmldom.so.1 (0x00007fc9a283a000)
libkmlengine.so.1 => /lib64/libkmlengine.so.1 (0x00007fc9a2601000)
libkmlxsd.so.1 => /lib64/libkmlxsd.so.1 (0x00007fc9a23ed000)
libkmlregionator.so.1 => /lib64/libkmlregionator.so.1 (0x00007fc9a21e2000)
libexpat.so.1 => /lib64/libexpat.so.1 (0x00007fc9a1fb8000)
libxerces-c-3.1.so => /lib64/libxerces-c-3.1.so (0x00007fc9a1a17000)
libopenjp2.so.7 => /lib64/libopenjp2.so.7 (0x00007fc9a17e1000)
libjasper.so.1 => /lib64/libjasper.so.1 (0x00007fc9a1588000)
libnetcdf.so.11 => /lib64/libnetcdf.so.11 (0x00007fc99e17e000)
libhdf5.so.10 => /lib64/libhdf5.so.10 (0x00007fc99dcb8000)
libogdi.so.3 => /lib64/libogdi.so.3 (0x00007fc99da97000)
libgif.so.4 => /lib64/libgif.so.4 (0x00007fc99d88d000)
libjpeg.so.62 => /lib64/libjpeg.so.62 (0x00007fc99d623000)
libgeotiff.so.2 => /lib64/libgeotiff.so.2 (0x00007fc99d3ef000)
libtiff.so.5 => /lib64/libtiff.so.5 (0x00007fc99d17b000)
libgta.so.0 => /lib64/libgta.so.0 (0x00007fc99cf70000)
libpng16.so.16 => /lib64/libpng16.so.16 (0x00007fc99cd3d000)
libcfitsio.so.2 => /lib64/libcfitsio.so.2 (0x00007fc99c964000)
libpq.so.5 => /lib64/libpq.so.5 (0x00007fc99c734000)
liblzma.so.5 => /lib64/liblzma.so.5 (0x00007fc99c50c000)
librt.so.1 => /lib64/librt.so.1 (0x00007fc99c304000)
libdapclient.so.6 => /lib64/libdapclient.so.6 (0x00007fc99c0b9000)
libdapserver.so.7 => /lib64/libdapserver.so.7 (0x00007fc99bea9000)
libdap.so.21 => /lib64/libdap.so.21 (0x00007fc99bb17000)
libspatialite.so.7 => /lib64/libspatialite.so.7 (0x00007fc99b394000)
libsqlite3.so.0 => /lib64/libsqlite3.so.0 (0x00007fc99b0bb000)
libpcre.so.1 => /lib64/libpcre.so.1 (0x00007fc99ae48000)
libcurl.so.4 => /lib64/libcurl.so.4 (0x00007fc99abca000)
libxml2.so.2 => /lib64/libxml2.so.2 (0x00007fc99a863000)
libmysqlclient.so.18 => /usr/lib64/mysql/libmysqlclient.so.18 (0x00007fc99a2bb000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fc99a09d000)
libz.so.1 => /lib64/libz.so.1 (0x00007fc999e85000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007fc999c81000)
libssl.so.10 => /lib64/libssl.so.10 (0x00007fc999a15000)
libcrypto.so.10 => /lib64/libcrypto.so.10 (0x00007fc9995b5000)
libwx_baseu_xml-3.0.so.0 => /lib64/libwx_baseu_xml-3.0.so.0 (0x00007fc9993a5000)
libwx_baseu_net-3.0.so.0 => /lib64/libwx_baseu_net-3.0.so.0 (0x00007fc999154000)
libwx_baseu-3.0.so.0 => /lib64/libwx_baseu-3.0.so.0 (0x00007fc998cbd000)
libpolyclipping.so.18 => /lib64/libpolyclipping.so.18 (0x00007fc998aa2000)
/lib64/ld-linux-x86-64.so.2 (0x000055d45788e000)
libopenblaso.so.0 => /lib64/libopenblaso.so.0 (0x00007fc9967a1000)
liblapack.so.3 => /lib64/liblapack.so.3 (0x00007fc995fa2000)
libarpack.so.2 => /lib64/libarpack.so.2 (0x00007fc995d56000)
libsuperlu.so.5.1 => /lib64/libsuperlu.so.5.1 (0x00007fc995ae0000)
liblcms2.so.2 => /lib64/liblcms2.so.2 (0x00007fc995882000)
libssl3.so => /lib64/libssl3.so (0x00007fc995636000)
libsmime3.so => /lib64/libsmime3.so (0x00007fc99540f000)
libnss3.so => /lib64/libnss3.so (0x00007fc9950e5000)
libnssutil3.so => /lib64/libnssutil3.so (0x00007fc994eb7000)
libplds4.so => /lib64/libplds4.so (0x00007fc994cb3000)
libplc4.so => /lib64/libplc4.so (0x00007fc994aac000)
libnspr4.so => /lib64/libnspr4.so (0x00007fc99486d000)
libfontconfig.so.1 => /lib64/libfontconfig.so.1 (0x00007fc994629000)
libfreetype.so.6 => /lib64/libfreetype.so.6 (0x00007fc99437e000)
libgeos-3.5.0.so => /lib64/libgeos-3.5.0.so (0x00007fc993fce000)
libltdl.so.7 => /lib64/libltdl.so.7 (0x00007fc993dc4000)
libminizip.so.1 => /lib64/libminizip.so.1 (0x00007fc993bb6000)
liburiparser.so.1 => /lib64/liburiparser.so.1 (0x00007fc99399b000)
libkmlconvenience.so.1 => /lib64/libkmlconvenience.so.1 (0x00007fc99377e000)
libnsl.so.1 => /lib64/libnsl.so.1 (0x00007fc993565000)
libhdf5_hl.so.10 => /lib64/libhdf5_hl.so.10 (0x00007fc993343000)
libproj.so.9 => /lib64/libproj.so.9 (0x00007fc9930e8000)
libSM.so.6 => /lib64/libSM.so.6 (0x00007fc992ee0000)
libICE.so.6 => /lib64/libICE.so.6 (0x00007fc992cc4000)
libX11.so.6 => /lib64/libX11.so.6 (0x00007fc992985000)
libjbig.so.2.1 => /lib64/libjbig.so.2.1 (0x00007fc992779000)
libbz2.so.1 => /lib64/libbz2.so.1 (0x00007fc992569000)
libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x00007fc99231a000)
libldap_r-2.4.so.2 => /lib64/libldap_r-2.4.so.2 (0x00007fc9920bf000)
libuuid.so.1 => /lib64/libuuid.so.1 (0x00007fc991eba000)
libnghttp2.so.14 => /lib64/libnghttp2.so.14 (0x00007fc991c95000)
libidn2.so.0 => /lib64/libidn2.so.0 (0x00007fc991a73000)
libssh2.so.1 => /lib64/libssh2.so.1 (0x00007fc991844000)
libpsl.so.5 => /lib64/libpsl.so.5 (0x00007fc991636000)
libkrb5.so.3 => /lib64/libkrb5.so.3 (0x00007fc991350000)
libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x00007fc99111f000)
libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007fc990f1b000)
liblber-2.4.so.2 => /lib64/liblber-2.4.so.2 (0x00007fc990d0c000)
libldap-2.4.so.2 => /lib64/libldap-2.4.so.2 (0x00007fc990ab8000)
libgfortran.so.3 => /lib64/libgfortran.so.3 (0x00007fc990787000)
libblas.so.3 => /lib64/libblas.so.3 (0x00007fc990530000)
libtatlas.so.3 => /usr/lib64/atlas/libtatlas.so.3 (0x00007fc98f771000)
libquadmath.so.0 => /lib64/libquadmath.so.0 (0x00007fc98f531000)
libsatlas.so.3 => /usr/lib64/atlas/libsatlas.so.3 (0x00007fc98e788000)
libxcb.so.1 => /lib64/libxcb.so.1 (0x00007fc98e560000)
libkrb5support.so.0 => /lib64/libkrb5support.so.0 (0x00007fc98e351000)
libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007fc98e14d000)
libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fc98df32000)
libsasl2.so.3 => /lib64/libsasl2.so.3 (0x00007fc98dd13000)
libunistring.so.2 => /lib64/libunistring.so.2 (0x00007fc98d9e3000)
libXau.so.6 => /lib64/libXau.so.6 (0x00007fc98d7df000)
libselinux.so.1 => /lib64/libselinux.so.1 (0x00007fc98d5b8000)
libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fc98d382000)
libfreebl3.so => /lib64/libfreebl3.so (0x00007fc98d17d000)

Comment 1 Volker Fröhlich 2017-02-04 20:25:35 UTC
Odd, I can see it too, along with other errors:

[2017-02-04/21:04:18] Load library: /usr/lib64/saga/libio_grid_grib2.so...failed
[2017-02-04/21:04:24] Load library: /usr/lib64/saga/libio_gdal.so...failed
[2017-02-04/21:04:27] Load tool chain: /usr/share/saga/toolchains/imagery.xml...failed
[2017-02-04/21:04:27] Load tool chain: /usr/share/saga/toolchains/tta_tools.xml...failed
[2017-02-04/21:04:27] Load tool chain: /usr/share/saga/toolchains/climate.xml...failed
[2017-02-04/21:04:28] Load tool chain: /usr/share/saga/toolchains/terrain_analysis.xml...failed

I tried to install saga-python and saga-devel, just to be sure. The messages disappeared. However, after removing the two, the error messages are not coming back. This needs further investigation.

Comment 2 Juan Pucheu 2017-02-04 21:04:25 UTC
(In reply to Volker Fröhlich from comment #1)
> Odd, I can see it too, along with other errors:
> 
> [2017-02-04/21:04:18] Load library:
> /usr/lib64/saga/libio_grid_grib2.so...failed
> [2017-02-04/21:04:24] Load library: /usr/lib64/saga/libio_gdal.so...failed
> [2017-02-04/21:04:27] Load tool chain:
> /usr/share/saga/toolchains/imagery.xml...failed
> [2017-02-04/21:04:27] Load tool chain:
> /usr/share/saga/toolchains/tta_tools.xml...failed
> [2017-02-04/21:04:27] Load tool chain:
> /usr/share/saga/toolchains/climate.xml...failed
> [2017-02-04/21:04:28] Load tool chain:
> /usr/share/saga/toolchains/terrain_analysis.xml...failed
> 
> I tried to install saga-python and saga-devel, just to be sure. The messages
> disappeared. However, after removing the two, the error messages are not
> coming back. This needs further investigation.

saga-python was installed on my system. After first run, saga doesn't try to load the failed modules, so all the displayed modules reports "okay"

Comment 3 Volker Fröhlich 2017-02-04 21:05:29 UTC
I see!

Comment 4 Fedora End Of Life 2017-11-16 18:43:29 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 5 Fedora End Of Life 2017-12-12 10:29:58 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.