Bug 1419306 - [RFE] Need to have group cli option to set all md-cache options using a single command
Summary: [RFE] Need to have group cli option to set all md-cache options using a singl...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: md-cache
Version: 3.10
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On: 1418249
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-05 07:08 UTC by Atin Mukherjee
Modified: 2017-03-06 17:45 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: Enhancement
Doc Text:
Clone Of: 1418249
Environment:
Last Closed: 2017-03-06 17:45:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2017-02-05 07:08:02 UTC
+++ This bug was initially created as a clone of Bug #1418249 +++

Description of problem:

To set md-cache options using a single command , there is group cli option needed for the same.

 gluster volume set <volname> features.cache-invalidation on
  gluster volume set <volname> features.cache-invalidation-timeout 600
  gluster volume set <volname> performance.stat-prefetch on
  gluster volume set <volname> performance.cache-samba-metadata on     : Not needed in case of non-samba 
  gluster volume set <volname> performance.cache-invalidation on
  gluster volume set <volname> performance.md-cache-timeout 600
Version-Release number of selected component (if applicable):

--- Additional comment from Worker Ant on 2017-02-01 06:45:18 EST ---

REVIEW: https://review.gluster.org/16503 (extras: Provide group set for md-cache and invalidation options) posted (#1) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Worker Ant on 2017-02-02 05:14:16 EST ---

REVIEW: https://review.gluster.org/16503 (extras: Provide group set for md-cache and invalidation options) posted (#2) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Worker Ant on 2017-02-03 04:33:20 EST ---

COMMIT: https://review.gluster.org/16503 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 75c398d396bcd4a50a5bdbe350d2de9d53ebac09
Author: Poornima G <pgurusid@redhat.com>
Date:   Wed Feb 1 17:11:46 2017 +0530

    extras: Provide group set for md-cache and invalidation options
    
    To enable the integration of md-cache and invalidation features
    we need to perform 3 volume set options in a specific order.
    In order to ease this for user provide a group volume set option.
    
    Usage: gluster vol set <VOLNAME> group metadata-cache
    
    Change-Id: I9bf0fd4217aa2a1c7ffbdc93e879b10f87addeac
    BUG: 1418249
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: https://review.gluster.org/16503
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 1 Worker Ant 2017-02-05 07:27:37 UTC
REVIEW: https://review.gluster.org/16546 (extras: Provide group set for md-cache and invalidation options) posted (#1) for review on release-3.10 by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Worker Ant 2017-02-05 07:30:55 UTC
REVIEW: https://review.gluster.org/16546 (extras: Provide group set for md-cache and invalidation options) posted (#2) for review on release-3.10 by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Worker Ant 2017-02-06 15:38:10 UTC
COMMIT: https://review.gluster.org/16546 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit dccd2aca5adf93754e85dbe19788d6b947ca15da
Author: Poornima G <pgurusid@redhat.com>
Date:   Wed Feb 1 17:11:46 2017 +0530

    extras: Provide group set for md-cache and invalidation options
    
    To enable the integration of md-cache and invalidation features
    we need to perform 3 volume set options in a specific order.
    In order to ease this for user provide a group volume set option.
    
    Usage: gluster vol set <VOLNAME> group metadata-cache
    
    >Reviewed-on: https://review.gluster.org/16503
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: I9bf0fd4217aa2a1c7ffbdc93e879b10f87addeac
    BUG: 1419306
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: https://review.gluster.org/16546
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 4 Shyamsundar 2017-03-06 17:45:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.