Bug 1419314 - SRIOV instance is ending in ERROR state due to port binding failure.
Summary: SRIOV instance is ending in ERROR state due to port binding failure.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 8.0 (Liberty)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Brent Eagles
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-05 11:00 UTC by VIKRANT
Modified: 2020-03-11 15:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-08 13:57:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description VIKRANT 2017-02-05 11:00:42 UTC
Description of problem:
Instance spawned using SRIOV Port is going into ERROR state because of port binding fail issue. 

Version-Release number of selected component (if applicable):
RHEL OSP 8

How reproducible:
Everytime for Cu. 

Steps to Reproduce:
1. Create a direct SRIOV port. 

# neutron port-create  f17484b3-2cfd-4400-86c1-c00cff976bcb  --name test-sriov725 --binding:vnic-type direct

2. Try to spawn an instance using the port.

# nova boot --flavor m1.medium  --image 754261a5-e231-422f-bd42-76cc839326f5 --nic port-id=4f6ce5a2-0576-4926-99aa-60facae7ba79 sriov-test

3. Instance is going into ERROR state.

# nova list
+--------------------------------------+------------+--------+------------+-------------+----------+
| ID                                   | Name       | Status | Task State | Power State | Networks |
+--------------------------------------+------------+--------+------------+-------------+----------+
| 31dba73f-80cb-4303-93e2-88e746dc870a | sriov-test | ERROR  | -          | NOSTATE     |          |
+--------------------------------------+------------+--------+------------+-------------+----------+

Actual results:
Instance is going into ERROR state. 

Expected results:
Instance should be in ACTIVE state. 

Additional info:
Configuration seems to be fine.

Comment 5 Assaf Muller 2017-05-08 13:54:48 UTC
Assigned to Brent for further triaging.

Comment 7 Assaf Muller 2017-05-08 13:57:05 UTC
Actually looking at the customer case the issue was since resolved.


Note You need to log in before you can comment on or make changes to this bug.