Bug 1419315 - cannot open /etc/fstab: No such file
Summary: cannot open /etc/fstab: No such file
Keywords:
Status: CLOSED DUPLICATE of bug 1224795
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-05 11:11 UTC by Vyacheslav Anzhiganov
Modified: 2017-02-06 08:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-05 12:09:33 UTC


Attachments (Terms of Use)

Description Vyacheslav Anzhiganov 2017-02-05 11:11:19 UTC
Description of problem:

infinite numbers of error messages:

RTNETLINK answers: File exists
/sbin/dhclient-script: 34: /sbin/dhclient-script: cannot open /etc/fstab: No such file

Version-Release number of selected component (if applicable):


How reproducible:

On Ubuntu Xenial 

virt-builder fedora-20 --arch x86_64 --hostname test3 --output /var/lib/libvirt/images/test3.qcow2 --root-password password:password123 -v

or 

virt-builder ubuntu-16.04 --arch x86_64 --hostname test3 --output /var/lib/libvirt/images/test3.qcow2 --root-password password:password123 -v

Actual results:

/sbin/dhclient-script: 34: /sbin/dhclient-script: cannot open /etc/fstab: No such file
RTNETLINK answers: File exists
/sbin/dhclient-script: 34: /sbin/dhclient-script: cannot open /etc/fstab: No such file
RTNETLINK answers: File exists
/sbin/dhclient-script: 34: /sbin/dhclient-script: cannot open /etc/fstab: No such file
RTNETLINK answers: File exists
/sbin/dhclient-script: 34: /sbin/dhclient-script: cannot open /etc/fstab: No such file
RTNETLINK answers: File exists

Comment 1 Richard W.M. Jones 2017-02-05 12:09:33 UTC
This is a bug in Ubuntu, see:

https://bugs.launchpad.net/ubuntu/+source/libguestfs/+bug/1632405

Comment 2 Pino Toscano 2017-02-06 08:47:44 UTC
It was worked around locally, see bug 1224795.

*** This bug has been marked as a duplicate of bug 1224795 ***


Note You need to log in before you can comment on or make changes to this bug.