Bug 1419337 - Random Generator setting did not saved after reboot
Summary: Random Generator setting did not saved after reboot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.1.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.1
: 4.1.1.2
Assignee: Shahar Havivi
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-05 14:34 UTC by Israel Pinto
Modified: 2017-04-21 09:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Previously, if the RNG configuration was changed on a running VM, after restart of the VM the configuration was not properly restored. Please note that the fix takes effect only on VMs which have been restarted on the fixed version of the engine.
Clone Of:
Environment:
Last Closed: 2017-04-21 09:45:53 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
rule-engine: blocker+
rule-engine: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
engine.log (512.23 KB, application/zip)
2017-02-05 14:34 UTC, Israel Pinto
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71866 0 master MERGED core: Random Generator setting wrong value after saving next run configuration 2017-02-09 07:23:34 UTC
oVirt gerrit 71948 0 ovirt-engine-4.1 MERGED core: Random Generator setting wrong value after saving next run configuration 2017-02-09 09:18:40 UTC

Description Israel Pinto 2017-02-05 14:34:29 UTC
Created attachment 1247821 [details]
engine.log

Description of problem:
Setting Random Generator parameters: Period duration (ms),
Bytes per period did not saved after rebooting VM

Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.1.0.3-0.1.el7

How reproducible:
All the time


Steps to Reproduce:
1. Run VM
2. Edit VM: Random Generator 
   Set parameters: Period duration (ms),Bytes per period
3. Press OK
4. Reboot VM 
5. Open Edit VM and check Random Generator parameters

Actual results:
Parameters are not set


Expected results:
Parameters will be set

Comment 1 Red Hat Bugzilla Rules Engine 2017-02-06 08:23:45 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Israel Pinto 2017-02-12 11:43:57 UTC
Verify with:
Engine: Red Hat Virtualization Manager Version: 4.1.1-0.1.el7
Host:
OS Version:RHEL - 7.3 - 7.el7
Kernel Version:3.10.0 - 550.el7.x86_64
KVM Version:2.6.0 - 28.el7_3.3.1
LIBVIRT Version:libvirt-2.0.0-10.el7_3.4
VDSM Version:vdsm-4.19.5-1.el7ev
SPICE Version:0.12.4 - 20.el7_3

Steps:
1. Create new VM 
2. Run VM
3. Edit VM and set RNG values
4. Reboot VM and check RNG values
5. Rerun 3-4 with exists running VM 

Results:
1. With new VM - PASS
2. With exist running VM (before upgrade to last version) - Failed

Comment 3 Shahar Havivi 2017-02-12 13:05:41 UTC
(In reply to Israel Pinto from comment #2)
> Verify with:
> Engine: Red Hat Virtualization Manager Version: 4.1.1-0.1.el7
> Host:
> OS Version:RHEL - 7.3 - 7.el7
> Kernel Version:3.10.0 - 550.el7.x86_64
> KVM Version:2.6.0 - 28.el7_3.3.1
> LIBVIRT Version:libvirt-2.0.0-10.el7_3.4
> VDSM Version:vdsm-4.19.5-1.el7ev
> SPICE Version:0.12.4 - 20.el7_3
> 
> Steps:
> 1. Create new VM 
> 2. Run VM
> 3. Edit VM and set RNG values
> 4. Reboot VM and check RNG values
> 5. Rerun 3-4 with exists running VM 
> 
> Results:
> 1. With new VM - PASS
> 2. With exist running VM (before upgrade to last version) - Failed

What do you mean Israel?
It will only work with a upgraded version

Comment 4 Israel Pinto 2017-02-13 12:36:37 UTC
Verify with:
Engine: Red Hat Virtualization Manager Version: 4.1.1-0.1.el7
Host:
OS Version:RHEL - 7.3 - 7.el7
Kernel Version:3.10.0 - 550.el7.x86_64
KVM Version:2.6.0 - 28.el7_3.3.1
LIBVIRT Version:libvirt-2.0.0-10.el7_3.4
VDSM Version:vdsm-4.19.5-1.el7ev
SPICE Version:0.12.4 - 20.el7_3

Steps:
1. Create new VM 
2. Run VM
3. Edit VM and set RNG values
4. Reboot VM and check RNG values
5. Reboot exists Vm and Rerun steps 3-4 

All PASS


Note You need to log in before you can comment on or make changes to this bug.