Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1419338 - RPM SPEC file should not attempt to install gtk stuff when bootstrap option selected
Summary: RPM SPEC file should not attempt to install gtk stuff when bootstrap option s...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libfm
Version: 24
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-05 14:45 UTC by a3d35232
Modified: 2017-02-06 09:44 UTC (History)
4 users (show)

Fixed In Version: libfm-1.2.5-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 09:44:21 UTC
Type: Bug


Attachments (Terms of Use)

Description a3d35232 2017-02-05 14:45:16 UTC
Summary of problem:
The libfm.spec file in the source RPM has a global "bootstrap" which, when set to 1, causes just the libfm-extra components to be built.  This is to get round the circular dependency between libfm and menu-config.  When this option is selected, the install code to do with GTK2 (lines 277-292 of the spec file) fails because those objects have not been built.

Version-Release number of selected component (if applicable):
1.2.3-10 onwards

Steps to Reproduce:
1. Edit libfm.spec and set bootstrap to 1 in line 6
2. rpmbuild -bb libfm.spec

Actual results:
Build fails when line 284 of spec file executed. (diff -urNp .%{_datadir}/%{name} $RPM_BUILD_ROOT/%{_datadir}/%{name})

Expected results:
Build succeeds.

Additional info:
Workaround is to change line 277 of libfm.spec from
   %if 0%{?fedora} >= 22
to
   %if ! 0%{?bootstrap}
   %if 0%{?fedora} >= 22
and line 292 from
   %endif
to
   %endif
   %endif

Comment 1 Mamoru TASAKA 2017-02-06 09:44:21 UTC
Fixed only for rawhide. For stable branches, the fix will be merged when additional change occur.


Note You need to log in before you can comment on or make changes to this bug.