Bug 141934 - Anaconda crashes installing packages
Anaconda crashes installing packages
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-12-06 03:23 EST by John Summerfield
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-01 22:23:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The kickstart file for this install (3.49 KB, text/plain)
2004-12-06 03:25 EST, John Summerfield
no flags Details

  None (edit)
Description John Summerfield 2004-12-06 03:23:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020

Description of problem:
This is a kickstart install, and the same install works fine on an HP
Vectra with 256 Mbytes RAM.

This test machine is a Dell optiplex GXa Pentium II 300 Mhz.
I am attempting a network kickstart text-mode install.

I was able to do a network manual GUI install.

The last package accessed on my web server is
libgcc-3.4.2-6.fc3.i386.rpm H

As you can see from the photo above, there is no opportunity to
conduct any forensics: Anaconda crashes and the system promptly reboots.

It happens every time on this machine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Choose your Dell GXa
2. PXE-boot my kickstart file
3. Make a cuppa:-)

Actual Results:  Anconda crash, temination messages scattered over the

Expected Results:  Clean install.

Additional info:
Comment 1 John Summerfield 2004-12-06 03:25:36 EST
Created attachment 107936 [details]
The kickstart file for this install

This is the same ks file used for my initscripts bug and which I emailed to
Comment 2 Jeremy Katz 2004-12-06 11:09:48 EST
You're basically getting a sig11 when package installation starts. If
this is reproducible on this machine, you might want to run memtest86+
to check the memory...
Comment 3 John Summerfield 2004-12-06 17:54:44 EST
Well, I _did_ do a manual gui install w/o problems.
memtest has completed one pass without error.

I booted into rescue mode (could we have a kickstart-style resuce
mode?) and found the install log. There were three packages listed as
installed. Not much of note.
Comment 4 John Summerfield 2004-12-07 07:38:53 EST
memtest has been running 14 hours and 18 minutes.
No errors.
Comment 5 John Summerfield 2004-12-07 07:59:18 EST
I gave up on the unexciting memorytest and tried an fc3 kickstart.
Failed too, looked like the same point.

ks file available on request.

Note: I'm using http installs; if you want to patch something bear
that in mind and give me clear instructions about what goes where.

I could try fc2 if you're interested.

Comment 6 John Summerfield 2004-12-08 19:45:21 EST
Might this be running out of memory?

I tried a manual install of _everything_  on the same machine and that
crashed similarly except that 
a. it did not automatically reboot
b. It happened earlier.

One of the VC displays showed Kernel Killer knocked off Anaconda.

I suggest Anaconda be changed to check whether this might be likely
and offer the possibility of using a swap file. It has got past disk
formatting, so the swap file is feasible.
Comment 7 Jeremy Katz 2005-02-01 22:23:42 EST
We recommend using swap.  If you continue and don't create a swap partition,
then weird things can happen.

Note You need to log in before you can comment on or make changes to this bug.