Bug 1419345 - kernel 4.9 fails to complete hardware shutdown or reboot
Summary: kernel 4.9 fails to complete hardware shutdown or reboot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-05 16:48 UTC by bernard.godard
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-15 18:34:20 UTC
Type: Bug


Attachments (Terms of Use)

Description bernard.godard 2017-02-05 16:48:57 UTC
Description of problem:

Since upgrading from kernel 4.8.16-300 to 4.9.5-200, the shutdown or reboot sequences do not complete. It seems like the shutdown sequence is performed, the screens lose the signal from the PC, but the hardware stays powered (I have to use the reboot button to perform a reboot or to press for a long time on the power button to shutdown the hardware.

The last lines of the system log are:

Feb 05 14:55:19 saturn systemd[1]: Reached target Unmount All Filesystems.
Feb 05 14:55:19 saturn systemd[1]: Reached target Final Step.
Feb 05 14:55:19 saturn systemd[1]: Starting Power-Off...
Feb 05 14:55:19 saturn systemd[1]: Shutting down.
Feb 05 14:55:21 saturn systemd-shutdown[1]: Sending SIGTERM to remaining processes...
Feb 05 14:55:21 saturn systemd-journald[614]: Journal stopped


Some hardware information from taken from lshw output (without classes: storage, volume and disk):
H/W path                   Device      Class       Description
==============================================================
                                       system      To be filled by O.E.M. (SKU)
/0                                     bus         M5A97 R2.0
/0/0                                   memory      64KiB BIOS
/0/4                                   processor   AMD FX(tm)-8350 Eight-Core Processor
/0/4/5                                 memory      384KiB L1 cache
/0/4/6                                 memory      8MiB L2 cache
/0/4/7                                 memory      8MiB L3 cache
/0/2c                                  memory      8GiB System Memory
/0/2c/0                                memory      DIMM Synchronous [empty]
/0/2c/1                                memory      4GiB DIMM DDR3 Synchronous Unbuffered (Unregistered) 1333 MHz (0.8 ns)
/0/2c/2                                memory      DIMM Synchronous [empty]
/0/2c/3                                memory      4GiB DIMM DDR3 Synchronous Unbuffered (Unregistered) 1333 MHz (0.8 ns)
/0/100                                 bridge      RD9x0/RX980 Host Bridge
/0/100/2                               bridge      RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GFX port 0)
/0/100/2/0                             display     Juniper XT [Radeon HD 6770]
/0/100/2/0.1                           multimedia  Juniper HDMI Audio [Radeon HD 5700 Series]
/0/100/4                               bridge      RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GPP Port 0)
/0/100/4/0                 enp2s0      network     RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
/0/100/5                               bridge      RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GPP Port 1)
/0/100/5/0                             bus         ASM1042 SuperSpeed USB Host Controller
/0/100/5/0/0               usb8        bus         xHCI Host Controller
/0/100/5/0/1               usb9        bus         xHCI Host Controller
/0/100/7                               bridge      RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GPP Port 3)
/0/100/7/0                             bus         ASM1042 SuperSpeed USB Host Controller
/0/100/7/0/0               usb10       bus         xHCI Host Controller
/0/100/7/0/0/2                         bus         USB2.0 Hub
/0/100/7/0/1               usb11       bus         xHCI Host Controller
/0/100/7/0/1/2                         bus         USB3.0 Hub

/0/100/12                              bus         SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/12/1                usb4        bus         OHCI PCI host controller
/0/100/12.2                            bus         SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/12.2/1              usb1        bus         EHCI Host Controller
/0/100/13                              bus         SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/13/1                usb5        bus         OHCI PCI host controller
/0/100/13/1/1                          generic     eHome Infrared Transceiver
/0/100/13/1/4                          input       USB Receiver
/0/100/13.2                            bus         SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/13.2/1              usb2        bus         EHCI Host Controller

/0/100/14                              bus         SBx00 SMBus Controller
/0/100/14.2                            multimedia  SBx00 Azalia (Intel HDA)
/0/100/14.3                            bridge      SB7x0/SB8x0/SB9x0 LPC host controller
/0/100/14.4                            bridge      SBx00 PCI to PCI Bridge
/0/100/14.4/6                          multimedia  CX23880/1/2/3 PCI Video and Audio Decoder
/0/100/14.4/6.1                        multimedia  CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port]
/0/100/14.4/6.2                        multimedia  CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port]
/0/100/14.5                            bus         SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
/0/100/14.5/1              usb6        bus         OHCI PCI host controller
/0/100/16                              bus         SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/16/1                usb7        bus         OHCI PCI host controller
/0/100/16.2                            bus         SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/16.2/1              usb3        bus         EHCI Host Controller
/0/101                                 bridge      Family 15h Processor Function 0
/0/102                                 bridge      Family 15h Processor Function 1
/0/103                                 bridge      Family 15h Processor Function 2
/0/104                                 bridge      Family 15h Processor Function 3
/0/105                                 bridge      Family 15h Processor Function 4
/0/106                                 bridge      Family 15h Processor Function 5

/1                         virbr0      network     Ethernet interface
/2                         virbr0-nic  network     Ethernet interface

Version-Release number of selected component (if applicable):
problem appears with kernel 4.9.5-200 and kernel 4.9.6-200
if I boot with 4.8.16-300, I don't see this problem.

How reproducible:
always with this hardware and kernels.


Steps to Reproduce:
Click on shutdown or reboot icon.

Actual results:
Shutdown/reboot sequence starts.
Screens go black and report no signal.
Hardware stays powered (LED on, noise from fans...) and then nothing happens.

Expected results:
Hardware shutdown or reboot.

Additional info:
I have used this particular hardware with many Linux distributions and I don't remember having encountered that particular problem except maybe with some Live distributions.
If I boot Fedora with previous kernel 4.8.16-300, I don't see this problem.
Thus this does not look like a hardware failure but likely a kernel regression.

Comment 1 bernard.godard 2017-02-06 11:14:08 UTC
After I had accidentally put my computer to sleep (accidental press on keyboard multimedia power button), I find that I can shutdown the computer properly.

This is also reproducible:
1 press keyboard multimedia power button
-> computer hibernates, fans are off (no noise) but power LED keeps blinking.
2 press any keyboard button:
-> computer wakes up
3 click on shutdown
-> complete shutdown, fans off, power LED off

The shutdown only completes if the computer has been hibernated since boot.

Comment 2 bernard.godard 2017-02-14 15:17:31 UTC
It seems to be fixed in kernels 
- 4.9.7-201
- 4.9.8-201

Comment 3 bernard.godard 2017-02-14 15:18:07 UTC
It seems to be fixed in kernels 
- 4.9.7-201
- 4.9.8-201

Comment 4 Laura Abbott 2017-02-15 18:34:20 UTC
Thank you for letting us know.


Note You need to log in before you can comment on or make changes to this bug.