Bug 141935 - AGPMode option freezes system with Radeon M9
Summary: AGPMode option freezes system with Radeon M9
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-06 08:24 UTC by Jeff Cheng
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 04:19:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (3.23 KB, text/plain)
2004-12-06 08:25 UTC, Jeff Cheng
no flags Details

Description Jeff Cheng 2004-12-06 08:24:26 UTC
Description of problem:
I have a Dell Inspiron 5150 with a Radeon Mobility 9000 (M9) and am
using the default radeon driver.  Whenever I set the AGPMode option to
 2 or 4 in xorg.conf, my system freezes.  Unfortunately, nothing can
be found to be logged.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21
kernel-2.6.9-1.681_FC3

How reproducible:
always

Steps to Reproduce:
1. Start X with 'Option "AGPMode" "4"' in device section of xorg.conf
with radeon driver.
  
Actual results:
System/X freezes.

Expected results:
X starts with agp set to 4x mode.

Additional info:
If I start X without the AGPMode option, dri is enabled and agp is set
to 1x mode. Other options, such as AGPFastWrite and EnablePageFlip,
work fine.

Comment 1 Jeff Cheng 2004-12-06 08:25:41 UTC
Created attachment 107937 [details]
xorg.conf

Comment 2 Mike A. Harris 2004-12-22 13:23:12 UTC
AGPMode and AGPSize are development options which shouldn't really
be used by end users.  The setting must match what the BIOS is
configured to use.  If it isn't, then the behaviour is undefined.

What is your CMOS set to for AGP mode?  Is it hard coded, or
configurable?  If it is hard coded, then using the AGPMode option
is basically undefined, and instability is probable and expected.

Comment 3 Jeff Cheng 2004-12-22 17:41:58 UTC
AGP mode is not configurable in the Dell BIOS, so I guess I'm stuck at 1x.

Comment 4 Mike A. Harris 2005-02-01 04:19:23 UTC
Unfortunately, that seems to be the case.  ;o/

Setting status to "NOTABUG"


Note You need to log in before you can comment on or make changes to this bug.