Bug 1419356 - Fails to accept any sudo rules if there are two user entries in an ldap role with the same sudo user.
Summary: Fails to accept any sudo rules if there are two user entries in an ldap role ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.3
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: shridhar
URL:
Whiteboard:
: 1420409 (view as bug list)
Depends On:
Blocks: 1298243 1422183
TreeView+ depends on / blocked
 
Reported: 2017-02-05 21:18 UTC by aheverle
Modified: 2020-07-16 09:11 UTC (History)
9 users (show)

Fixed In Version: sssd-1.15.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1422183 (view as bug list)
Environment:
Last Closed: 2017-08-01 09:02:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 4334 None None None 2020-05-02 18:37:02 UTC
Red Hat Product Errata RHEA-2017:2294 normal SHIPPED_LIVE sssd bug fix and enhancement update 2017-08-01 12:39:55 UTC

Description aheverle 2017-02-05 21:18:31 UTC
Description of problem:
sssd-1.14.0-43.el7_3.11.x86_64 fails to accept any sudo rules if there are two user entries in an ldap role with the same sudo user. This is an issue because on RHEL 6   sssd-1.13.3-22.el6_8.4.x86_64 requires the use of both lower and upper case usernames for the sudo rules to work.

Version-Release number of selected component (if applicable):
sssd-1.14.0-43.el7_3.11.x86_64

Additional info:
Bug already filed upstream

storing a sudo rule with sudoRule attribute values that only differ by case fails
 - https://fedorahosted.org/sssd/ticket/3301

Comment 1 Jakub Hrozek 2017-02-06 07:05:10 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3301

Comment 3 Jakub Hrozek 2017-02-10 16:02:24 UTC
Fixed upstream:
    master:
        a5ecc93abb01cece628fdef04ebad43bba267419 
    sssd-1-14:
        d5ddca8b44d00b92d4a70ea90d48247635a4e1ca

Comment 8 Jakub Hrozek 2017-02-15 10:34:18 UTC
*** Bug 1420409 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2017-08-01 09:02:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2294


Note You need to log in before you can comment on or make changes to this bug.