Bug 1419390 - hawkular-openshift-agent do not work on OCP 3.5
Summary: hawkular-openshift-agent do not work on OCP 3.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Matt Wringe
QA Contact: Peng Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 02:44 UTC by Peng Li
Modified: 2017-07-24 14:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-12 19:11:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Peng Li 2017-02-06 02:44:45 UTC
Description of problem:
Deploy hawkular-openshift-agent on OCP 3.5 failed, from the log can see error like  stat /opt/hawkular/hawkular-openshift-agent: no such file or directory

Version-Release number of selected component (if applicable):
openshift v3.5.0.16+a26133a
metrics-hawkular-openshift-agent   3.5.0   0896d559ade3        11 days ago

How reproducible:
always

Steps to Reproduce:
1. deploy Metrics 3.5(since there is bug using ansible, I'm using deployer) and check all pods works well

oc create -f - <<API
apiVersion: v1
kind: ServiceAccount
metadata:
  name: metrics-deployer
secrets:
- name: metrics-deployer
API

oadm policy add-role-to-user edit system:serviceaccount:openshift-infra:metrics-deployer

oc secrets new metrics-deployer nothing=/dev/null

oadm policy add-cluster-role-to-user cluster-reader system:serviceaccount:openshift-infra:heapster

oadm policy add-role-to-user view system:serviceaccount:openshift-infra:hawkular -n openshift-infra

oc new-app -f metrics.yaml --as=system:serviceaccount:openshift-infra:metrics-deployer \
-p IMAGE_PREFIX=$PREFIX \
-p IMAGE_VERSION=3.5.0 \
-p HAWKULAR_METRICS_HOSTNAME=hawkular-metrics.$SUBDOMAIN \
-p MODE=deploy \
-p USE_PERSISTENT_STORAGE=false \
-p MASTER_URL=$MASTERURL \
-p DYNAMICALLY_PROVISION_STORAGE=false \
-p CASSANDRA_NODES=1 \
-p CASSANDRA_PV_SIZE=10Gi \
-p USER_WRITE_ACCESS=false

]# oc get pod
NAME                         READY     STATUS      RESTARTS   AGE
hawkular-cassandra-1-t48j3   1/1       Running     0          14m
hawkular-metrics-34287       1/1       Running     0          14m
heapster-rpjx0               1/1       Running     0          14m
metrics-deployer-ndhb6       0/1       Completed   0          14m


2.git clone https://github.com/hawkular/hawkular-openshift-agent.git, modify 
hawkular-openshift-agent.yaml, change IMAGE_VERSION and registry

3.deploy the agent

oc create -f deploy/openshift/hawkular-openshift-agent-configmap.yaml -n openshift-infra
oc process -f deploy/openshift/hawkular-openshift-agent.yaml | oc create -n openshift-infra -f -
oc adm policy add-cluster-role-to-user hawkular-openshift-agent system:serviceaccount:openshift-infra:hawkular-openshift-agen

Actual results:
hawkular-openshift-agent never getting to Running status.
# oc get pod
NAME                             READY     STATUS             RESTARTS   AGE
hawkular-cassandra-1-t48j3       1/1       Running            0          27m
hawkular-metrics-34287           1/1       Running            0          27m
hawkular-openshift-agent-14dts   0/1       CrashLoopBackOff   7          12m
hawkular-openshift-agent-3x7t0   0/1       CrashLoopBackOff   7          12m
heapster-rpjx0                   1/1       Running            0          27m
metrics-deployer-ndhb6           0/1       Completed          0          28m


Expected results:
Agent is deployed, hence use could get application level metrics.

Additional info:
Event attached.
This blocks test for https://trello.com/c/ZQTYWrCD/154-8-support-application-level-metrics-hawkular-evg-epic-ois-met-ux

Comment 1 Peng Li 2017-02-06 02:47:12 UTC
Created attachment 1247927 [details]
event.yaml

Comment 6 Peng Li 2017-02-10 05:54:12 UTC
verified with 3.5.0

metrics-hawkular-openshift-agent   3.5.0               a74520aaa07f        12 hours ago        234.8 MB

# oc get pod
NAME                             READY     STATUS      RESTARTS   AGE
hawkular-cassandra-1-z7pn0       1/1       Running     0          37m
hawkular-metrics-gdkp7           1/1       Running     0          31m
hawkular-openshift-agent-2lvgf   1/1       Running     0          2m
hawkular-openshift-agent-n2dcg   1/1       Running     0          2m
heapster-d4svp                   1/1       Running     0          2h
metrics-deployer-x4n6w           0/1       Completed   0          2h

Comment 8 errata-xmlrpc 2017-04-12 19:11:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.