Bug 141940 - unable to fall back to proper font correctly in titlebar
unable to fall back to proper font correctly in titlebar
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-06 04:15 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: fontconfig-2.3.95-11.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 02:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2004-12-06 04:15:37 EST
Description of problem:
When starting firefox with LANG=zh_TW in the bn_IN locale, the
application title bar falls back to the bitmap font instead of the
ttfont. As a result some of the characters cannot be displayed.

Version-Release number of selected component (if applicable):
fontconfig-2.2.3-7
bitmap-fonts-0.3-4
ttfonts-zh_TW-2.11-28

How reproducible:
Always

Steps to Reproduce:
1.log in as normal user at gdm into bn_IN locale
2.in gnome-terminal, LANG=zh_TW.UTF-8 firefox
3.
  
Actual results:
Unable to display zh_TW character in the application title bar.

Expected results:
Able to display zh_TW character in the application title bar.

Additional info:
Removing the bitmap-fonts-0.3-4 package will allow the application to
display the chars properly.
Comment 1 Leon Ho 2004-12-06 04:25:10 EST
It is probably a general case - 
1. the title bar is following the desktop locale instead of
application. 2. it is not using the correct font to fallback correctly
because it is not in that specific locale. 

2nd one is probably related to bug #107952, right?

(Changing summary into more general)
Comment 2 Lawrence Lim 2006-09-25 02:05:59 EDT
Cant reproduce the bug in FC6 anymore. Resolving.

firefox-1.5.0.6-11
fontconfig-2.3.95-11.fc6
fonts-chinese-3.02-6.fc6

Note You need to log in before you can comment on or make changes to this bug.