Bug 1419426 - Dovecot dsync not replicating ".dovecot.sieve -> .sieve/managesieve.sieve"
Summary: Dovecot dsync not replicating ".dovecot.sieve -> .sieve/managesieve.sieve"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dovecot
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: David Jež
URL:
Whiteboard:
Depends On:
Blocks: 1420851 1451294 1465906 1549619 1551541
TreeView+ depends on / blocked
 
Reported: 2017-02-06 06:24 UTC by Sham Antony
Modified: 2018-10-30 10:55 UTC (History)
2 users (show)

Fixed In Version: dovecot-2.2.36-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:54:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
Rebase against 2.2.32 and pigeonhole 0.4.20 (7.50 MB, application/octet-stream)
2017-10-03 21:43 UTC, Robert Giles
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3182 0 None None None 2018-10-30 10:55:11 UTC

Description Sham Antony 2017-02-06 06:24:57 UTC
Description of problem:

On host1, within a user's mail directory, after activating an Out of Office message in Roundcube, the .dovecot.sieve symbolic link is correctly created:

imap1:/VOLUMES/imapstore/rgiles# ls -la
total 8
drwxr-xr-x. 4 vmail vmail 102 Jan 10 13:50 .
drwxr-x---. 4 vmail vmail  33 Dec 21 13:56 ..
-rw-------. 1 vmail vmail  38 Jan 10 11:13 .dovecot.lda-dupes
lrwxrwxrwx. 1 vmail vmail  23 Jan 10 10:47 .dovecot.sieve -> sieve/managesieve.sieve

-rw-------. 1 vmail vmail 138 Jan 10 13:50 .dovecot.svbin
drwx------. 4 vmail vmail 149 Dec 21 14:14 mdbox
drwx------. 3 vmail vmail  42 Jan 10 11:14 sieve

On the other host, the symlink is *not* created properly (but the Sieve scripts *are* correctly propagated, as well as e-mail, etc.).

imap2:/VOLUMES/imapstore/rgiles# ls -la
total 0
drwxr-xr-x. 4 vmail vmail 32 Jan 13 13:32 .
drwxr-x---. 4 vmail vmail 33 Dec 21 13:58 ..
drwx------. 4 vmail vmail 86 Dec 21 14:14 mdbox
drwx------. 3 vmail vmail 42 Jan 10 11:14 sieve

This is a bug that is fixed in later versions of Dovecot-Pigeonhole (0.4.4 onward).

RHEL7 ships with dovecot-pigeonhole-2.2.10-7.el7.x86_64, which contains Pigeonhole 0.4.2.

This particular thread on the Dovecot list also describes the issue (and detailing that the problem was identified and fixed in a later version):

https://dovecot.org/list/dovecot/2015-February/099661.html

Version-Release number of selected component (if applicable):

dovecot-pigeonhole-2.2.10-7.el7.x86_64
dovecot-2.2.10-7.el7.x86_64

How reproducible:

Always

Steps to Reproduce:

Setup Dovecot dsync replication service on two hosts

Actual results:

The symlink is *not* created 

Expected results:

Create symlink

Comment 7 Robert Giles 2017-10-03 21:43:50 UTC
Created attachment 1333943 [details]
Rebase against 2.2.32 and pigeonhole 0.4.20

Figured we'd rebase a new RPM against 2.2.32.  It certainly fixes this bug, among others.

Comment 9 Robert Giles 2018-06-12 14:56:07 UTC
Thanks;  this is good to hear there will be an official RHEL-supported RPM of the terminal 2.2 Dovecot release (2.2.36).

Comment 14 errata-xmlrpc 2018-10-30 10:54:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3182


Note You need to log in before you can comment on or make changes to this bug.