Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1419427 - Refuse to connect console directly when type wrong password for vnc guest on rhel6
Summary: Refuse to connect console directly when type wrong password for vnc guest on ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.9
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 06:31 UTC by mxie@redhat.com
Modified: 2017-11-14 07:50 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 07:50:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
virt-manager-debug (8.16 KB, text/plain)
2017-02-06 06:31 UTC, mxie@redhat.com
no flags Details
screenshot (24.40 KB, image/png)
2017-02-06 06:32 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2017-02-06 06:31:06 UTC
Created attachment 1247953 [details]
virt-manager-debug

Description of problem:
Refuse to connect console directly when type wrong password for vnc guest on rhel6

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-34.el6.x86_64
libvirt-0.10.2-62.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.501.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Prepare a vnc guest with password setting in virt-manager
2. Open the guest console and type wrong password, the console is disconnected directly with error  "viewer connection to hypervisor host got refused or disconnected"


Actual results:
VNC guest can't keep the interface "password inputting" after inputting wrong password

Expected results:
Should popup dialog "Viewer authentication error: Authentication failed" and keep the interface "password inputting" after click ok of Authentication failed dialog

Additional info:
1.Spice guest could keep the interface "password inputting" after inputting wrong password
2.Can't reproduce this problem on rhel7.3

Comment 1 mxie@redhat.com 2017-02-06 06:32:52 UTC
Created attachment 1247954 [details]
screenshot

Comment 3 Cole Robinson 2017-03-29 18:22:55 UTC
Unless this is a very simple fix IMO it's WONTFIX for rhel6, given the age of the distro, and that this issue isn't a big deal

Comment 4 Jaroslav Suchanek 2017-11-14 07:50:03 UTC
This is not a critical bz which has to be addressed in rhel-6.10.


Note You need to log in before you can comment on or make changes to this bug.