Bug 1419431 - Stale gfid in quota.conf should be cleaned up.
Summary: Stale gfid in quota.conf should be cleaned up.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Sanoj Unnikrishnan
QA Contact: Vinayak Papnoi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 06:49 UTC by Sanoj Unnikrishnan
Modified: 2018-03-09 18:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-09 18:18:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sanoj Unnikrishnan 2017-02-06 06:49:17 UTC
Description:
For a directory with quota limit set, if an rmdir is done without prior remove limit on the path, the gfid corresponding to the dir remains in quota.conf.

This causes the quota.conf to grow. Each gfid entry takes 17 bytes (16:gfid, 1:type). So it grows very slowly.

Another issue that stale gfid causes is that it increases ipc calls to quotad during list (one per gfid).

Proposed solution:
Since very few dirs would have limit set on them, it may be an overkill to handle these during rmdir. Instead we could clean them during quota list operation.


Note You need to log in before you can comment on or make changes to this bug.