Bug 1419432 - kernel panic "general protection no entropy gathe libc-2.24.90.so
Summary: kernel panic "general protection no entropy gathe libc-2.24.90.so
Keywords:
Status: CLOSED DUPLICATE of bug 1401444
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 06:52 UTC by George R. Goffe
Modified: 2019-01-09 12:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 21:10:35 UTC
Type: Bug


Attachments (Terms of Use)
gziped flat file of the boot screens (9.49 KB, application/x-gzip)
2017-02-06 06:52 UTC, George R. Goffe
no flags Details

Description George R. Goffe 2017-02-06 06:52:55 UTC
Created attachment 1247956 [details]
gziped flat file of the boot screens

Description of problem:

After several rounds of heavy system update over the past 2 weeks, this system has started panicing. I waited... thinking that someone had seen the problem and had fixed it. I waited too long. Now, all 3 kernels panic with the same message (see below).

I have tried a different version of VirtualBox but am experiencing the same symptom.

Version-Release number of selected component (if applicable):
unknown

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
panic

Expected results:
normal boot

Additional info:

general protection ip:7f49c784f352 sp:7ffc6cd8dd70 error:0no entropy gathe[  110.765476]  in lib    332 c-2.24.90.so

Comment 1 Florian Weimer 2017-02-06 07:40:25 UTC
Do you use FIPS mode?  Could this be a duplicate of bug 1401444?

Comment 2 George R. Goffe 2017-02-06 20:47:39 UTC
Florian,

You are a GENIUS! I checked the rpms installed and there were several with fips in their name. I have removed them and now the system boots! YAY Florian!

Now I have to reinstall things like openssh (et. al.) and any other packages that "think" about FIPS things. 

Serves me right for blindly installing ALL packages. Oh well.

I would have no problem if you closed this bug but I'd like to suggest that if a user does something stupid like this, the kernel could issue a warning and NOT try to do FIPS like processing. NONE of my filesystems are encrypted.

Regards and THANKS for your help!

George...

Comment 3 Florian Weimer 2017-02-06 21:10:35 UTC
(In reply to George R. Goffe from comment #2)

> I would have no problem if you closed this bug but I'd like to suggest that
> if a user does something stupid like this, the kernel could issue a warning
> and NOT try to do FIPS like processing. NONE of my filesystems are encrypted.

I think part of the requirement of FIPS mode is that it may not silently transition to non-FIPS mode, so we can't do this.

The actual bug will be fixed in dracut.

*** This bug has been marked as a duplicate of bug 1401444 ***


Note You need to log in before you can comment on or make changes to this bug.