Bug 1419435 - node upgrade inherits /etc/redhat-release
Summary: node upgrade inherits /etc/redhat-release
Keywords:
Status: CLOSED DUPLICATE of bug 1417534
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-ng
Version: 4.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.1.0-beta
: ---
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 07:04 UTC by Roman Hodain
Modified: 2017-02-06 14:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 14:30:52 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)

Description Roman Hodain 2017-02-06 07:04:10 UTC
Description of problem:
Node upgrade copies over /etc/redhat-release which in some cases can cause confusion. In case of upgrade from RHEL 7.2 to 7.3 the file still contains 7.2 version.

Version-Release number of selected component (if applicable):
rhvh-4.0-0.20170104

How reproducible:
100%

Steps to Reproduce:
1. Modify /etc/redhat-release
2. proceed with upgrade

Actual results:
/etc/redhat-release changes are kept.

Expected results:
New information is included

Additional info:

[root@ng01 ~]# cat /etc/redhat-release /etc/os-release 
Red Hat Enterprise Linux release 7.2
NAME="Red Hat Enterprise Linux"
VERSION="7.3"
VERSION_ID="7.3"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Red Hat Virtualization Host"
VARIANT_ID="ovirt-node"
PRETTY_NAME="Red Hat Virtualization Host 4.0 (el7.3)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.3:GA:hypervisor"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

# FIXME
REDHAT_BUGZILLA_PRODUCT="Red Hat Virtualization"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.3
REDHAT_SUPPORT_PRODUCT="Red Hat Virtualization"
REDHAT_SUPPORT_PRODUCT_VERSION=7.3

Comment 1 Ryan Barry 2017-02-06 14:30:52 UTC

*** This bug has been marked as a duplicate of bug 1417534 ***


Note You need to log in before you can comment on or make changes to this bug.