Bug 1419483 - RHVH product version displays 4.0 in Subscription page with cockpit UI
Summary: RHVH product version displays 4.0 in Subscription page with cockpit UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor-ng
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.1
: ---
Assignee: Yuval Turgeman
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 10:18 UTC by Wei Wang
Modified: 2017-04-20 19:03 UTC (History)
13 users (show)

Fixed In Version: redhat-release-virtualization-host-4.1-0.10.el7
Doc Type: Bug Fix
Doc Text:
Previously, Red Hat Virtualization Host (RHVH) was shipped with a for version 4.0 certificate and as a result 4.0 appeared in the Subscription page instead of 4.1. In this release, the correct certificate has been shipped, and RHVH now displays 4.1 in the Subscription page.
Clone Of:
Environment:
Last Closed: 2017-04-20 19:03:00 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
log files (239.86 KB, application/x-gzip)
2017-02-06 10:18 UTC, Wei Wang
no flags Details
before register to rhsm (43.23 KB, image/png)
2017-02-06 10:18 UTC, Wei Wang
no flags Details
after register to rhsm (44.85 KB, image/png)
2017-02-06 10:19 UTC, Wei Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1114 0 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update 2017-04-20 22:57:46 UTC

Description Wei Wang 2017-02-06 10:18:02 UTC
Created attachment 1247992 [details]
log files

Description of problem:
RHVH product version displays 4.0 in Subscription page with cockpit UI

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.1-20170202.0
cockpit-ovirt-dashboard-0.10.7-0.0.6.el7ev.noarch
cockpit-ws-126-1.el7.x86_64
imgbased-0.9.6-0.1.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. Install RHVH 4.1
2. Login cockpit website hostIP:9090 with root account
3. Go to "Tools"--->"Subscriptions" page
4. Check the RHVH product version
5. Register to RHSM, check the RHVH product version



Actual results:
RHVH product version is displayed as 4.0. 

Expected results:
RHVH product version should be displayed as 4.1.


Additional info:

Comment 1 Wei Wang 2017-02-06 10:18:45 UTC
Created attachment 1247993 [details]
before register to rhsm

Comment 2 Wei Wang 2017-02-06 10:19:16 UTC
Created attachment 1247995 [details]
after register to rhsm

Comment 3 Ryan Barry 2017-02-07 04:11:52 UTC
Joey -

Do we need a new certificate?

Comment 6 Wei Wang 2017-02-27 06:12:05 UTC
Test with redhat-virtualization-host-4.1-20170222.0, the result is: RHVH product version is displayed as 4.0. So the bug is exist, change status to ASSIGNED.

Comment 7 Ryan Barry 2017-02-28 14:06:48 UTC
Joey, any ideas here?

I suspect we also need the new cert inside redhat-release-virtualization-host-content

Comment 9 Wei Wang 2017-03-10 08:51:34 UTC
Test version
redhat-virtualization-host-4.1-20170309.0
cockpit-ovirt-dashboard-0.10.7-0.0.15.el7ev.noarch
cockpit-ws-126-1.el7.x86_64
imgbased-0.9.17-0.1.el7ev.noarch

Test steps:
1. Install RHVH 4.1
2. Login cockpit website hostIP:9090 with root account
3. Go to "Tools"--->"Subscriptions" page
4. Check the RHVH product version
5. Register to RHSM, check the RHVH product version

Result:
RHVH product version is displayed as 4.1.


The bug is fixed, change the status to VERIFIED.

Comment 10 errata-xmlrpc 2017-04-20 19:03:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1114


Note You need to log in before you can comment on or make changes to this bug.