Bug 1419489 - Please rebuild for new gcc/fortran
Summary: Please rebuild for new gcc/fortran
Keywords:
Status: CLOSED DUPLICATE of bug 1417385
Alias: None
Product: Fedora
Classification: Fedora
Component: openblas
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 10:39 UTC by Jaroslav Škarvada
Modified: 2017-02-14 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 19:09:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Jaroslav Škarvada 2017-02-06 10:39:02 UTC
Description of problem:
Error: nothing provides libgfortran.so.3()(64bit) needed by openblas-threads64_-0.2.19-4.fc26.x86_64

Version-Release number of selected component (if applicable):
openblas-0.2.19-4.fc26

How reproducible:
Always

Steps to Reproduce:
1. E.g try to recompile hpl in f26

Actual results:
Compilation fails due to unsatisfied dependencies

Expected results:
No unsatisfied dependencies

Additional info:
It's blocking rebuild of hpl package.

Comment 1 Susi Lehtola 2017-02-06 19:09:48 UTC

*** This bug has been marked as a duplicate of bug 1192617 ***

Comment 2 Orion Poplawski 2017-02-06 19:31:43 UTC
Not quite sure this was marked as a dupe of 1192617.  openblas needs a rebuild, but fails on ppc64le due to:

../kernel/power/scopy_microk_power8.c: In function 'scopy_kernel_32':
../kernel/power/scopy_microk_power8.c:57:2: error: PIC register clobbered by '%2' in 'asm'
  __asm__  __volatile__
  ^~~~~~~
In file included from ../kernel/power/sdot.c:39:0:
../kernel/power/sdot_microk_power8.c: In function 'sdot_kernel_16':
../kernel/power/sdot_microk_power8.c:57:2: error: PIC register clobbered by '%2' in 'asm'
  __asm__  __volatile__
  ^~~~~~~

Which I'm assuming is a gcc bug.

Comment 3 Susi Lehtola 2017-02-06 21:02:55 UTC
(In reply to Orion Poplawski from comment #2)
> Not quite sure this was marked as a dupe of 1192617.

Yeah this wasn't actually the right bug since there's no broken modules in this case but a libgfortran soname bump.

But there is already a bug on the FTBFS problem.

*** This bug has been marked as a duplicate of bug 1417385 ***

Comment 4 Jaroslav Škarvada 2017-02-14 13:21:33 UTC
HPL rebuilt OK.


Note You need to log in before you can comment on or make changes to this bug.