Bug 1419497 - Allow disabling registry.access.redhat.com
Summary: Allow disabling registry.access.redhat.com
Keywords:
Status: CLOSED DUPLICATE of bug 1461465
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 10:56 UTC by Marko Myllynen
Modified: 2018-05-21 18:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-21 18:49:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marko Myllynen 2017-02-06 10:56:23 UTC
Description of problem:
The example Ansible byo inventory states:

# For enterprise deployment types we ensure that registry.access.redhat.com is
# included if you do not include it

This is backwards, in enterprise deployments no internet / upstream repositories should be enabled unconditionally, the administrator should have full control over the registries being setup. Especially in the case of enterprise, local registry mirrors are often used and internet access is not available / forbidden.

Please do not unconditionally enable registry.access.redhat.com or allow a configuration knob to disable it.

Version-Release number of selected component (if applicable):
3.4

Comment 1 Scott Dodson 2017-02-06 14:13:15 UTC
What's the impact of this in an environment where access to registry.access.redhat.com is blocked? Setting to low severity as I believe this won't actually break anything.

Comment 2 Marko Myllynen 2017-02-06 14:31:34 UTC
Correct, low prio, zero impact if you have "127.0.0.2 registry.access.redhat.com" in your /etc/hosts or firewall configured but those are needless extra steps compared to registry.access.redhat.com not being enabled at all. Thanks.

Comment 3 Scott Dodson 2017-02-06 14:48:47 UTC
If having registry.access.redhat.com forced into the docker config actually creates problems without putting in a garbage /etc/hosts entry in we should consider this a medium. If it's just cosmetic we'll leave it at low.

Comment 4 Scott Dodson 2018-05-21 18:49:54 UTC
Can be achieved by setting openshift_docker_ent_reg='' in 3.9 and later.

*** This bug has been marked as a duplicate of bug 1461465 ***


Note You need to log in before you can comment on or make changes to this bug.