Bug 1419531 - Many network adapters in inventory although there is only one visible in device mapper
Summary: Many network adapters in inventory although there is only one visible in devi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other
Version: JON 3.3.8
Hardware: Unspecified
OS: Windows
medium
high
Target Milestone: CR01
: JON 3.3.9
Assignee: Josejulio Martínez
QA Contact: Jeeva Kandasamy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 12:43 UTC by Filip Brychta
Modified: 2017-10-02 17:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-02 17:21:51 UTC
Type: Bug


Attachments (Terms of Use)
inventory screenshot (102.50 KB, image/png)
2017-02-06 12:43 UTC, Filip Brychta
no flags Details
device mapper screenshot (119.66 KB, image/png)
2017-02-06 12:44 UTC, Filip Brychta
no flags Details
device manager - network adapters (42.57 KB, image/png)
2017-08-23 23:33 UTC, Josejulio Martínez
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2846 normal SHIPPED_LIVE Red Hat JBoss Operations Network 3.3.9 bug fix update 2017-10-02 21:21:28 UTC

Description Filip Brychta 2017-02-06 12:43:39 UTC
Created attachment 1248029 [details]
inventory screenshot

Description of problem:
This issue is visible only on Windows. JON discovers many network adapters (jon_inventory.png) but there is only one visible in device mapper (dev_mapper.png)

Version-Release number of selected component (if applicable):
JON3.3.8.ER02

How reproducible:
Always

Steps to Reproduce:
1. install jon server on windows VM
2. import all resources and navigate to Platform->Network Adapters


Actual results:
See attached jon_inventory.png

Expected results:
Not sure. It's not clear if JON is discovering some virtual network devices but device mapper shows just one network adapter (dev_mapper.png).

Output of ipconfig -all:

c:\>ipconfig -all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : fbr-win2
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : openstacklocal

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : openstacklocal
   Description . . . . . . . . . . . : Red Hat VirtIO Ethernet Adapter
   Physical Address. . . . . . . . . : FA-16-3E-2C-E1-72
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::51ec:f306:464b:be58%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 172.16.131.92(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Monday, February 06, 2017 6:34:36 AM
   Lease Expires . . . . . . . . . . : Tuesday, February 07, 2017 6:34:37 AM
   Default Gateway . . . . . . . . . : 172.16.131.1
   DHCP Server . . . . . . . . . . . : 172.16.131.3
   DHCPv6 IAID . . . . . . . . . . . : 251270718
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-20-26-18-DD-FA-16-3E-2C-E1-72

   DNS Servers . . . . . . . . . . . : 172.16.131.3
                                       172.16.131.4
                                       172.16.131.2
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.openstacklocal:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : openstacklocal
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Comment 1 Filip Brychta 2017-02-06 12:44:04 UTC
Created attachment 1248030 [details]
device mapper screenshot

Comment 2 Josejulio Martínez 2017-08-23 23:33:36 UTC
Created attachment 1317329 [details]
device manager - network adapters

Did you check the device manager? It seems that there are more network adapters.

I'm not an expert on Sigar, but without digging much, seems like Sigar couldn't get their name[1] and just started naming them as eth0, eht1, etc.

[1] https://github.com/hyperic/sigar/blob/master/src/os/win32/win32_sigar.c#L2869-L2872

Comment 5 Josejulio Martínez 2017-08-30 15:20:17 UTC
commit 3f5df899057b43c8ef0685fc8b60421e6192f8be
Merge: df2cd91 4c69bc5
Author: Michael Burman <yak@iki.fi>
Date:   Wed Aug 30 08:29:19 2017 +0300

    Merge pull request #318 from josejulio/bugs/1419531
    
    Bug 1419531 - Use network device description for display name on windows

commit 4c69bc5c41659383e408bca7925606e400af33e2
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Tue Aug 29 18:31:03 2017 -0500

    Bug 1419531 - Use network device description for display name on windows

Comment 8 Simeon Pinder 2017-09-19 11:33:12 UTC
Moving to ON_QA.

JON 3.3.9 CR01 artifacts are available for test from here:
http://download.eng.bos.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/135/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip
 *Note: jon-server-patch-3.3.0.GA.zip maps to CR01 build of
 jon-server-3.3.0.GA-update-09.zip.

Comment 11 Sunil Kondkar 2017-09-25 05:41:02 UTC
Marking the bug as verified as per comment#10

Comment 12 errata-xmlrpc 2017-10-02 17:21:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2846


Note You need to log in before you can comment on or make changes to this bug.