Bug 1419533 - [3.2]Installation on node failed when creating node config
Summary: [3.2]Installation on node failed when creating node config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.2.1
Assignee: Andrew Butcher
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 12:51 UTC by Gaoyun Pei
Modified: 2017-03-06 16:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A change in Ansible 2.2.1.0 caused problems with the OCP 3.2 plabooks. We have worked around this change ensuring that playbooks run correctly on Ansible 2.2.1.0 and newer.
Clone Of:
Environment:
Last Closed: 2017-03-06 16:38:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0448 0 normal SHIPPED_LIVE Important: ansible and openshift-ansible security and bug fix update 2017-03-06 21:36:25 UTC

Description Gaoyun Pei 2017-02-06 12:51:49 UTC
Description of problem:
Installation failed due to error "AnsibleFilterError: Failed to convert: %s" when running TASK "[openshift_node : Create the Node config]".


Version-Release number of selected component (if applicable):
ansible-2.2.1.0-2.el7.noarch
openshift-ansible-3.2.49-1.git.0.fc41501.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.Prepare ansible inventory file and trigger install playbook.


Actual results:
TASK [openshift_node : set_fact] ***********************************************
Monday 06 February 2017  10:22:25 +0000 (0:00:00.107)       0:10:03.542 ******* 
ok: [ec2-54-82-180-189.compute-1.amazonaws.com] => {"ansible_facts": {"ovs_service_status_changed": false}, "changed": false}
ok: [ec2-52-87-198-161.compute-1.amazonaws.com] => {"ansible_facts": {"ovs_service_status_changed": false}, "changed": false}

TASK [openshift_node : Create the Node config] *********************************
Monday 06 February 2017  10:22:25 +0000 (0:00:00.119)       0:10:03.661 ******* 
fatal: [ec2-54-82-180-189.compute-1.amazonaws.com]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleFilterError: Failed to convert: %s"}
fatal: [ec2-52-87-198-161.compute-1.amazonaws.com]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleFilterError: Failed to convert: %s"}



Expected results:
No such error

Additional info:
Tried openshift-ansible-3.2.49-1 with ansible-2.2.0.0-1.el7, it works well.

Comment 3 Andrew Butcher 2017-02-06 18:16:08 UTC
Proposed fix https://github.com/openshift/openshift-ansible/pull/3267

Comment 5 Gaoyun Pei 2017-02-10 05:10:41 UTC
Verify this bug with openshift-ansible-3.2.50-1.git.0.df25cf2.el7.noarch.rpm and ansible-2.2.1.0-2.el7

Node config creation step could be done and the whole installation is successful.

Comment 7 errata-xmlrpc 2017-03-06 16:38:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:0448


Note You need to log in before you can comment on or make changes to this bug.