Bug 1419560 - Provisioning exception
Summary: Provisioning exception
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1271086;VARIANT_ID=workstat...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 13:55 UTC by Hedayat Vatankhah
Modified: 2017-02-06 17:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 14:38:20 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.08 KB, text/plain)
2017-02-06 13:55 UTC, Hedayat Vatankhah
no flags Details

Description Hedayat Vatankhah 2017-02-06 13:55:22 UTC
Description of problem:
Tried to open Help->Install new software

Version-Release number of selected component:
eclipse-platform-4.6.2-6.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        /usr/bin/java -Dosgi.requiredJavaVersion=1.8 -Xms512m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -Dosgi.framework.extensions=org.eclipse.wst.jsdt.nashorn.extension -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.201.v20170109-1424.jar -os linux -ws gtk -arch x86_64 -showsplash /usr/lib64/eclipse//plugins/org.eclipse.platform_4.6.2.v20170109-1424/splash.bmp -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.401.v20170109-1424/eclipse_1618.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.201.v20170109-1424.jar -protect master --launcher.appendVmargs -exitdata e8008 -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.8 -Xms512m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -Dosgi.framework.extensions=org.eclipse.wst.jsdt.nashorn.extension -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.201.v20170109-1424.jar
eclipseplugin:  org.eclipse.equinox.p2.core
executable:     /usr/lib64/eclipse/plugins/org.eclipse.equinox.p2.core_2.4.100.v20170109-1424.jar
kernel:         4.9.6-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           libreport
uid:            1000

Truncated backtrace:
org.eclipse.equinox.p2.core.ProvisionException: No repository found at http://download.eclipse.org/releases/neon/201605271000.
	at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.fail(AbstractRepositoryManager.java:395)
	at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:653)
	at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:96)
	at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:92)
	at org.eclipse.equinox.p2.ui.LoadMetadataRepositoryJob.doLoad(LoadMetadataRepositoryJob.java:117)
	at org.eclipse.equinox.p2.ui.LoadMetadataRepositoryJob.runModal(LoadMetadataRepositoryJob.java:102)
	at org.eclipse.equinox.internal.p2.ui.sdk.PreloadingRepositoryHandler$2.runModal(PreloadingRepositoryHandler.java:83)
	at org.eclipse.equinox.p2.operations.ProvisioningJob.run(ProvisioningJob.java:177)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Comment 1 Hedayat Vatankhah 2017-02-06 13:55:28 UTC
Created attachment 1248041 [details]
File: backtrace

Comment 2 Mat Booth 2017-02-06 14:38:20 UTC
http://download.eclipse.org/releases/neon/201605271000 does not appear to be a valid update site

Did you mean to use http://download.eclipse.org/releases/neon/ ?

Comment 3 Hedayat Vatankhah 2017-02-06 17:23:14 UTC
I don't know. I've not added that update site myself! I have 3 entries: http://download.eclipse.org/releases/neon/, http://download.eclipse.org/releases/neon/201605271000 and another one! All of them were enabled. I've used Eclipse market place, I don't know if it has added such entries.

Comment 4 Mat Booth 2017-02-06 17:37:38 UTC
(In reply to Hedayat Vatankhah from comment #3)
> I don't know. I've not added that update site myself! I have 3 entries:
> http://download.eclipse.org/releases/neon/,
> http://download.eclipse.org/releases/neon/201605271000 and another one! All
> of them were enabled. I've used Eclipse market place, I don't know if it has
> added such entries.

This is possible. Which plugins did you install from market place? It's likely one of them was relying on an old, pre-release snapshot of Eclipse Neon and did not make appropriate updates for the release of Neon.
 
It is safe to remove this site from the list and use only http://download.eclipse.org/releases/neon/


Note You need to log in before you can comment on or make changes to this bug.