Bug 1419652 - Multicast should be supported in vnid 0
Summary: Multicast should be supported in vnid 0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.5.0
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dan Winship
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 16:26 UTC by Weibin Liang
Modified: 2017-07-24 14:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-04-12 19:11:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Origin (Github) 12839 0 None None None 2017-02-07 14:22:35 UTC
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Weibin Liang 2017-02-06 16:26:47 UTC
Description of problem:
Pods in the admin tenant (default project) should be able to send/receive multicast traffic from other admin tenant pods, bu in latest 3.5 code, multicast does not work in vnid 0

Version-Release number of selected component (if applicable):
oc v3.5.0.16+a26133a
kubernetes v1.5.2+43a9be4
openshift v3.5.0.16+a26133a
kubernetes v1.5.2+43a9be4

How reproducible:
Every time.

Steps to Reproduce:
1. oc project default
2. oc annotate netnamespace default netnamespace.network.openshift.io/multicast-enabled=true
3. oc create -f https://raw.githubusercontent.com/weliang1/Openshift_Networking/master/OSE3.3/multicast.json
4. oc rsh hello-pod-1
   iperf -c 232.43.211.234 -u -T 32 -t 3000 -i 1
5. oc rsh hello-pod-2
   iperf -s -u -B 232.43.211.234  -i 1



Actual results:
hello-pod-2 does not receive multicast traffic sent from hello-pod-1

Expected results:
hello-pod-2 should receive multicast traffic sent from hello-pod-1

Additional info:

Comment 1 Troy Dawson 2017-02-08 22:28:08 UTC
This has been merged into ocp and is in OCP v3.5.0.18 or newer.

Comment 3 Weibin Liang 2017-02-09 15:57:22 UTC
Test case passed in oc v3.5.0.18+9a5d1aa

Comment 5 errata-xmlrpc 2017-04-12 19:11:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.