Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1419666 - Upgrade Scala version
Summary: Upgrade Scala version
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: scala
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Will Benton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 17:08 UTC by Demi Marie Obenour
Modified: 2017-02-06 17:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 17:42:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Demi Marie Obenour 2017-02-06 17:08:42 UTC
Description of problem:
Scala is version 2.10.4.  This is rather old; version 2.12.1 is the latest release.

Version-Release number of selected component (if applicable):
2.10.4

How reproducible:
Always.

Steps to Reproduce:
1. Install the Fedora package for Scala
2. Run scala -version

Actual results:
Scala is only version 2.10.4.

Expected results:
Scala is version 2.12.1 or comparable (the latest upstream at the time Fedora 25 was packaged).

Additional info:
This prevents Scala from being used with many releases of out-of-tree software, such as Apache Spark.

Comment 1 Will Benton 2017-02-06 17:42:39 UTC
Scala in Rawhide is 2.10.6, which is the latest in the 2.10 series.  We are working on adding Scala 2.11 and ultimately 2.12, but those will be as separate packages (to preserve compatibility with packages that only work on 2.10).  In any case, Apache Spark is compatible with both Scala 2.10 and 2.11.

Since other Scala releases will be added as new packages, I am closing this bug (since the existing Scala package will remain 2.10).


Note You need to log in before you can comment on or make changes to this bug.