Bug 141969 - The megaraid_mbox driver doesn't fully replace old megaraid driver
Summary: The megaraid_mbox driver doesn't fully replace old megaraid driver
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hwdata   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-06 14:52 UTC by Chris Adams
Modified: 2014-03-17 02:51 UTC (History)
1 user (show)

Fixed In Version: 0.151-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 22:54:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to pcitable to switch most MegaRAID entries back to old driver (4.25 KB, patch)
2004-12-06 14:53 UTC, Chris Adams
no flags Details | Diff

Description Chris Adams 2004-12-06 14:52:22 UTC
When the megaraid_mbox driver was added, it looks like someone just
did s/megaraid/megaraid_mbox/ in the pcitable.  That is not correct
though, as megaraid_mbox only works with some cards.  This is causing
extra confusion with the new driver, as it is being loaded for cards
it doesn't recognize (and people aren't seeing that it doesn't
recognize the card, they are just seeing that no drives appeared).

Here is a patch that fixes that.  I did:

- s/megaraid_mbox/megaraid/

- took all the PCI IDs at the top of
drivers/scsi/megaraid/megaraid_mbox.c in the kernel source and
switched or added (some of them were not in the pcitable at all) those
entries to megaraid_mbox

Dave Jones said that he is going to re-enable the old megaraid driver
in future kernel builds (at least for now), so the PCI ID table should
be updated as well.

Comment 1 Chris Adams 2004-12-06 14:53:18 UTC
Created attachment 107951 [details]
Patch to pcitable to switch most MegaRAID entries back to old driver

Comment 2 Arkadiusz Miskiewicz 2005-01-15 18:57:17 UTC
Also it iterates devices in different order than old megaraid driver - for example under 
driver I had sda, sdb, sdc and now the same raid arrays are seen as sdc, sda, sdb, sdd - 
completly different order.

Comment 3 Bill Nottingham 2005-01-28 22:54:46 UTC
Changes committed to CVS for mapping those cards whose ids are only
supported by 'megaraid' to it... megaraid_mbox is still preferred for
cards it supports.

Will be in 0.151-1.


Note You need to log in before you can comment on or make changes to this bug.