Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1419708 - Update documentation to account for new names for fence agent parameters
Summary: Update documentation to account for new names for fence agent parameters
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Cluster_General
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Steven J. Levine
QA Contact:
URL:
Whiteboard:
Depends On: 1403028
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 19:59 UTC by Steven J. Levine
Modified: 2019-06-05 14:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1403028
Environment:
Last Closed: 2019-06-05 14:58:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 3 Steven J. Levine 2017-08-10 20:02:22 UTC
Marek:

I'm looking at all of my open BZs and I'm not sure what to do with this one.

In the RHEL 7 HA manuals, we do not document the fence agent parameters for each fence agent (as we do for RHEL 6), because that information can be found realidy with a "pcs stonith describe" command.  But I thought I might have to update any fence configuration example that uses any of the updated parameters.

But in looking at the pcs help screens -- as well as BZ#1403028 -- it looks as if the pcs command parameters have not changed for 7.4.

Are there plans to change the names of the fence parameters for pcs at this point?  If not, I can close this as not a bug since it doesn't affect existing documentation

Steven

Comment 4 Marek Grac 2017-08-11 07:41:55 UTC
@Steven:

You are right, they were not changed in pcs yet. There is a plan to do it in 7.5.

Comment 5 Steven J. Levine 2017-08-11 14:48:47 UTC
Keeping this BZ open for 7.5.

Thanks, Marek.

Comment 6 Steven J. Levine 2018-02-08 15:29:03 UTC
Marek:

This BZ had fallen by the wayside for a while.

For 7.5, should I update the parameter names in the example commands in the Pacemaker documentation that I noted in comment 2?

Steven

Comment 7 Marek Grac 2018-02-26 12:09:11 UTC
@Steven:

yes, please. In 7.5 we should prefer new names that are consistent with long options from command line (old one will work as well).

Comment 8 Steven J. Levine 2018-02-26 15:27:02 UTC
Marek:

If support in pcs for these new names is new for 7.5, should we put something in the release notes about this?  (Perhaps associated with BZ#1403028)?

Comment 10 Marek Grac 2018-02-28 13:50:19 UTC
Related bug: https://bugzilla.redhat.com/show_bug.cgi?id=1436217

I have talked to Tomas to confirm the situation. One day (7.6+ / plan for 8.0  ), only the new options will be shown by pcs and validation will be done in fence agents. Currently, there is no way how to do validation in fence agents via pcs so we have to wait a bit.


Note You need to log in before you can comment on or make changes to this bug.