Bug 1419712 - [RFE] add support for LUKS disk encryption format driver w/ RBD (qemu-kvm-rhev) TESTONLY
Summary: [RFE] add support for LUKS disk encryption format driver w/ RBD (qemu-kvm-rhe...
Keywords:
Status: CLOSED DUPLICATE of bug 1230405
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Yogev Rabl
QA Contact: Yogev Rabl
Derek
URL:
Whiteboard:
Depends On: 1301019
Blocks: 1411525 1442136
TreeView+ depends on / blocked
 
Reported: 2017-02-06 20:15 UTC by jomurphy
Modified: 2018-03-09 19:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-17 13:25:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jomurphy 2017-02-06 20:15:15 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Yogev Rabl 2017-06-06 15:53:58 UTC
This test has failed - there's no implementation of encrypted volumes in the RBD Cinder driver.

Every attempt to create an encrypt volume will fail due to this piece of code:
        if volume.encryption_key_id:
            message = _("Encryption is not yet supported.")
            raise exception.VolumeDriverException(message=message)

Comment 6 Sean Cohen 2017-11-17 13:25:44 UTC

*** This bug has been marked as a duplicate of bug 1230405 ***


Note You need to log in before you can comment on or make changes to this bug.