Bug 1419714 - Deploying a heat stack does not account for UTF-8 characters (e.g. french)
Summary: Deploying a heat stack does not account for UTF-8 characters (e.g. french)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.3.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Bill Wei
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 20:22 UTC by Freddy Wissing
Modified: 2020-03-11 15:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 17:43:55 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Freddy Wissing 2017-02-06 20:22:58 UTC
Description of problem:

When loading heat templates encoded in UTF-8 or with non-ascii characters. The customer is experiencing an ascii decoding error from the cloudforms VS heat api. 



  :body          => "{\"explanation\": \"The server could not comply with the request since it is either malformed or otherwise incorrect.\", \"code\": 400, \"error\": {\"message\": \"Failed to validate: 'ascii' codec can't decode byte 0xe2 in position 3525: ordinal not in range(128)\", \"traceback\": null, \"type\": \"StackValidationFailed\"}, \"title\": \"Bad Request\"}"


Version-Release number of selected component (if applicable):

5.3.3

How reproducible:

Reliably

Steps to Reproduce:
1. Load heat templates containing UTF-8 chars.
2. Attempt to deploy a heat stack.


Actual results:

  :body          => "{\"explanation\": \"The server could not comply with the request since it is either malformed or otherwise incorrect.\", \"code\": 400, \"error\": {\"message\": \"Failed to validate: 'ascii' codec can't decode byte 0xe2 in position 3525: ordinal not in range(128)\", \"traceback\": null, \"type\": \"StackValidationFailed\"}, \"title\": \"Bad Request\"}"


Expected results:

Deployment would proceed.


Additional info:

An example of the character issue (note the quotation marks):

diff RHEL-Base.yaml RHEL-Base.yaml.old
118c118
<            if [ "$OS_MAJOR_VERSION" == "7" ]; then
---
>            if [ “$OS_MAJOR_VERSION” == “7” ]; then

Comment 2 Bill Wei 2017-02-06 22:55:48 UTC
This issue is considered as an user error. We don't do any decoding or translation of the template content but simply pass it through to the provider. It is user's responsibility to submit a valid template acceptable by the provider (and the version).

In this particular example non-ascii quotation “ is completely different from ascii ". Even an decoding cannot convert one to the other, but ascii " is essential to identify a variable or value.

I would recommend close this BZ as NOTABUG

Comment 3 Freddy Wissing 2017-02-07 13:13:37 UTC
I will advise the customer of same.

Comment 4 Freddy Wissing 2017-02-07 17:43:55 UTC
Message relayed to the customer.

Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.