Bug 1419722 - Host check for upgrade should be allowed only if host is UP
Summary: Host check for upgrade should be allowed only if host is UP
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: future
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.1.1
: ---
Assignee: Ravi Nori
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 21:23 UTC by Ravi Nori
Modified: 2017-02-07 09:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 09:40:21 UTC
oVirt Team: Infra
rule-engine: ovirt-4.1+


Attachments (Terms of Use)

Description Ravi Nori 2017-02-06 21:23:17 UTC
When the host status is in non-responsive or maintenance status host upgrade check should not be performed as the condition of the host in unknown.

Version-Release number of selected component (if applicable): 4.1


Steps to Reproduce:
1. Add 3.6 host to DC with cluster level 4.0. Host will be added in and moved to non-responsive state
2. Trigger or wait for host upgrade check

Actual results:

The host upgrade check fails due to package mismatch between versions

Expected results:

Host upgrade check should not be invoked as the host is in non-responsive state.

Comment 1 Martin Perina 2017-02-07 05:55:34 UTC
Check for upgrades will be executed only for hosts in Up state.

Comment 2 Martin Perina 2017-02-07 09:40:21 UTC
Disabling check for upgrades in Maintenance status was covered by BZ1343562. This bug should disable check for upgrades also in NonOperational state, but after offline discussion I'd say that we want to check for upgrades for host in NonOperational, because we wouldn't be able to execute Upgrade otherwise.

It also needs to be mentioned that original flow behind this bug (add 3.6 host into 4.0 cluster and execute check for upgrades on it) is not that relevant, because:

1. Hosts have to be upgraded first before you can upgrade cluster level
2. If you add older host to newer cluster level, it becomes NonOperational and check for upgrade fails for it, but there may be various other why host is NonOperation and check for upgrade is still successful.

Due to above reasons I'm closing this one as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.