Bug 141975 - RFE: allow user creation before config rollout during ks
RFE: allow user creation before config rollout during ks
Status: CLOSED DUPLICATE of bug 141974
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-06 10:20 EST by Patrick C. F. Ernzer
Modified: 2011-01-26 09:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-21 05:03:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2004-12-06 10:20:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When I ks a system and select rollout configs, this seems to be done
before the text I can enter in the %post section box of the ks.

This is a PITA when trying to roll out files that belong to a user
that is added during post.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create config files that are owned by a user (e.g. pcfe.pcfe)
2. bind these files to an activation key
3. kickstart a system, selecting rollout copnfigs, with that
activation key
4. have 'adduser pcfe' in the %post filed of said kickstart

Actual Results:  config rollout fails with getpwname failed (user does
not seem to exist at config rollout time)

Expected Results:  config rollout suceeds

Additional info:

This seems to requires either a "create the following users" field in
the kickstart details, or a way to have the whole %post section
execute before config rollout happens
Comment 1 Robin Norwood 2006-10-17 12:56:20 EDT
mass reassign to mmccune
Comment 4 Miroslav Suchý 2011-01-21 05:03:27 EST

*** This bug has been marked as a duplicate of bug 141974 ***

Note You need to log in before you can comment on or make changes to this bug.