Bug 1419776 - [3.5] oc cluster up pulling origin images
Summary: [3.5] oc cluster up pulling origin images
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Steve Kuznetsov
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 02:14 UTC by Wang Haoran
Modified: 2017-03-02 22:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-02 22:15:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wang Haoran 2017-02-07 02:14:04 UTC
Description of problem:


Version-Release number of selected component (if applicable):
oc cluster up pulling origin images

How reproducible:


Steps to Reproduce:
1.oc cluster up
-- Checking OpenShift client ... OK
-- Checking Docker client ... OK
-- Checking Docker version ... OK
-- Checking for existing OpenShift container ... OK
-- Checking for openshift/origin:v3.5.0.16 image ... 
   Pulling image openshift/origin:v3.5.0.16
FAIL
   Error: error pulling Docker image openshift/origin:v3.5.0.16
   Caused By:
     Error: manifest unknown: manifest unknown
2.
3.

Actual results:


Expected results:
pulling the images from registry.access.redhat.com

Additional info:

Comment 1 Cesar Wong 2017-02-07 14:19:52 UTC
Steve, sending this one your way since you're addressing this. In the 3.4 branch of OSE, the registry for OSE is correct [1]. But I imagine it is reverted in 3.5 because we're starting with origin again? [2]

[1] https://github.com/openshift/ose/blob/enterprise-3.4/pkg/bootstrap/docker/up.go#L134
[2] https://github.com/openshift/ose/blob/master/pkg/bootstrap/docker/up.go#L228

Comment 2 Steve Kuznetsov 2017-02-07 15:18:42 UTC
Once we pick up the ldflag change [1] in the OSE rebase we will need to provide the correct envars [2] during the build and we should be good here. Not sure why we see a regression. I was not under the impression that we had begun the rebases or rewritten any git history in OSE master yet.

[1] https://github.com/openshift/origin/pull/12758/commits/5237fda6a1f1fc0ca770ac04071e07ab30b8de2a
[2] OS_IMAGE_PREFIX=openshift3/ose
    OS_BUILD_LDFLAGS_DEFAULT_IMAGE_STREAMS=rhel7

Comment 3 Troy Dawson 2017-02-20 16:04:36 UTC
Sorry, I forgot to reply to this.
The newer ose rpms (atomic-openshift) are built with these options.
It should be working now I believe on at least atomic-openshift-3.5.0.31 or newer.

Comment 4 Wang Haoran 2017-02-23 02:09:55 UTC
Verified with:
openshift v3.5.0.32-1+4f84c83
kubernetes v1.5.2+43a9be4
etcd 3.1.0

Comment 5 Troy Dawson 2017-03-02 22:15:34 UTC
Since this bug never reached customers, I am closing it.


Note You need to log in before you can comment on or make changes to this bug.