Bug 1419782 - [devenv] Can not change memory add-on when a user has two projects
Summary: [devenv] Can not change memory add-on when a user has two projects
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 3.x
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Abhishek Gupta
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 03:17 UTC by yasun
Modified: 2017-03-20 09:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-20 09:56:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description yasun 2017-02-07 03:17:46 UTC
Description of problem:
If a user have two projects. increase/decrease memory add-on will be failed with "internal server error"

Version-Release number of selected component (if applicable):
openshift v3.4.1.2
kubernetes v1.4.0+776c994

How reproducible:
always

Steps to Reproduce:
1. Set up an Online developer environment
2. Register an openshift account via accountant web console 
3. Create two project via openshift web console with the account
4. Start to increase the memory add-on. 
5. Start to descrease the memory add-on.



Actual results:
Account web console response "internal server error". And from account pod log:
helper.go:93] error: Resource violations: plan requires 1 project(s) but found 2

Expected results:
increase/descrease memory add-on successfully


Additional info:

Comment 1 yasun 2017-02-07 07:18:51 UTC
so is increasing/descreasing storage add-on.

Comment 2 Abhishek Gupta 2017-02-07 17:08:31 UTC
This is being caused by a validation failure. OpenShift is configured to allow users to create up to 10 projects. However, the accountant validates that users have only a maximum of 1 project, based on plan configuration. The plan configuration is being modified in the accountant and should be available tomorrow.

Comment 3 yasun 2017-02-09 09:14:56 UTC
Version-Release number of online-int:
OpenShift Master:   v3.4.1.2 (online version 3.4.1.4)
Kubernetes Master:  v1.4.0+776c994 

Test on online-int, the project limit number for good plan has been updated to 10, and create several projects, and then increase/decrease memory/storage add-on successfully.


Note You need to log in before you can comment on or make changes to this bug.