Bug 1419815 - Failed to boot a VM with a virtual function attached
Summary: Failed to boot a VM with a virtual function attached
Keywords:
Status: CLOSED DUPLICATE of bug 1420446
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1335596 1406834
TreeView+ depends on / blocked
 
Reported: 2017-02-07 06:49 UTC by surya
Modified: 2017-02-10 15:45 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-10 15:45:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
Templates used to deploy overcloud (9.41 KB, application/x-gzip)
2017-02-07 06:49 UTC, surya
no flags Details
nova-compute.log file from the compute node (407.45 KB, text/plain)
2017-02-07 06:51 UTC, surya
no flags Details

Description surya 2017-02-07 06:49:41 UTC
Created attachment 1248287 [details]
Templates used to deploy overcloud

Description of problem:

We are facing an issue with sriov functionality in RH OSP 10. When we  configure 15 Virtual Functions on the compute node we are able to boot VM’s with VF attached to it.

But when we configure the same compute node with 32 VF’s we are not able to boot VM’s with VF attached

Output seen with nova show 
| fault                                | {"message": "Exceeded maximum number of retries. Exceeded max scheduling attempts 3 for instance 2fd03d1c-5152-499a-9fc8-8caaa3d346a7. Last exception: error dumping ens2f1 (3) interface: Message too long", "code": 500, "details": "  File \"/usr/lib/python2.7/site-packages/nova/conductor/manager.py\", line 492, in build_instances |



Version-Release number of selected component (if applicable):

RH OSP 10

How reproducible:

100% reproducible when the virtual function count is 32

Steps to Reproduce:
1. deploy the overcloud by setting virtual function count to 32
2. create a sriov port
neutron port-create pvt --binding:vnic-type direct 
3. boot a VM with the port created in the 2nd step

SRIOV nic model: Intel Corporation 82599ES 10-Gigabit 
  

Actual results:

Output seen with nova show 
| fault                                | {"message": "Exceeded maximum number of retries. Exceeded max scheduling attempts 3 for instance 2fd03d1c-5152-499a-9fc8-8caaa3d346a7. Last exception: error dumping ens2f1 (3) interface: Message too long", "code": 500, "details": "  File \"/usr/lib/python2.7/site-packages/nova/conductor/manager.py\", line 492, in build_instances |


Expected results:

VM should boot with a sriov nic attached

Additional info:

Comment 1 surya 2017-02-07 06:51:02 UTC
Created attachment 1248288 [details]
nova-compute.log file from the compute node

Comment 3 Ollie Walsh 2017-02-10 15:45:59 UTC

*** This bug has been marked as a duplicate of bug 1420446 ***


Note You need to log in before you can comment on or make changes to this bug.