Bug 1419820 - Missing identifiers (for Selenium automation) in the plans list table
Summary: Missing identifiers (for Selenium automation) in the plans list table
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Jason E. Rist
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 07:23 UTC by Udi
Modified: 2018-04-09 11:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-09 11:28:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 538362 0 None None None 2018-01-26 23:11:23 UTC

Description Udi 2017-02-07 07:23:25 UTC
Description of problem:
1) The plan name in the field should have an id "plan_name".
2) The "Edit" button should have an id "ListPlans__editPlanButton". 
3) The "Delete" button has a class name "ListPlans__editPlanButton" (which is supposed to be the id of the edit button), and doesn't have an id "ListPlans__deletePlanButton".

If it's not possible to give several elements the same id (these elements appear many times, in every row of the table) - it's alright if these identifiers will be classes instead. However currently they're found on the wrong elements or nowhere at all.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-2.0.1-0.20170126144317.f3bd97e.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Right-click on the elements in the plans table, and choose "Inspect" to see their attributes.

Comment 1 Udi 2017-06-07 15:30:21 UTC
This is still needed. This is in the plan management page, the elements there still don't have IDs.

Comment 2 Udi 2017-07-09 10:52:22 UTC
The GUI was rewritten for Pike, but the bug is still valid (although there is no more a "plans table" and the other elements described in the original bug). We need identifiers on the plan cards, tha plan names, the kebab menu and the menu items in it etc...

Comment 4 Jason E. Rist 2018-01-26 23:11:24 UTC
I've put a patch up for this upstream.  Please take a look.

https://review.openstack.org/538362

Since the things you're asking for like ListPlans__editPlanButton are not buttons and also could possibly appear multiple times, I removed the word Button and also made them classes.  You can see how to access them once you acquire the .plan-card with something like a query selector.

Comment 6 Udi 2018-04-09 11:28:45 UTC
This won't be tested because it takes too long for the identifiers to trickle down stream, and in the mean time some of the identifiers were removed by upstream because they didn't know what they were important for. This issue will be solved as soon as the automation code is upstream.


Note You need to log in before you can comment on or make changes to this bug.