Bug 141984 - setting kernel parameters at bootup give soft hang with ati firegl x1 installed
setting kernel parameters at bootup give soft hang with ati firegl x1 installed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-06 11:19 EST by Stephen Adler
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 08:42:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Adler 2004-12-06 11:19:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I loaded an AMD64 system with fc3 and Matrox G450 card installed.
The install went fine, the system booted fine, and system was fully
operational. I then switched out the Matrox G450 card for an ATI
FireGL X1 card, (x8 AGP), and when the system boots, it hangs during
rc.sysinit when the script is running sysctl. At this point,
I can issue a ^C and the system continues booting (i.e. soft
hang) but this breaks out of rc.sysinit and does not finish
executing some important code, (i.e. like remounting the
file systems in read/write mode.) The system becomes non-operational.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load fc3 on an amd64 system and a ATI FireGL x1 card
2. Try and boot...
3.
    

Additional info:
Comment 1 Karel Zak 2004-12-07 08:06:05 EST
sysctl is called more times in rc.sysinit, when it hang up? During
"Configuring kernel parameters: ..."?

What do you have in the file /etc/sysctl.conf?

Can you try after complete boot do as root:

   # sysctl -e -p /etc/sysctl.conf
Comment 2 Stephen Adler 2004-12-07 09:39:31 EST
yes, its during the "Configuring kernel parameters: ...". The problem
is that I can't boot into an operational state since the system
hangs at the "Configuring kernel parameters:..." state. Do you know
how I can boot up without it configuring the kernel? Is there a
way to disable this step during boot up?
Comment 3 Karel Zak 2004-12-08 12:29:56 EST
You have to boot to "emergency" mode, see: 

http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/custom-guide/s1-rescuemode-booting-emergency.html

and edit the file /etc/rc.d/rc.sysinit. At line cca 234 you can found
code:

action $"Configuring kernel parameters: " sysctl -e -p /etc/sysctl.conf

please, disable this line by '#'

Now you can try boot to standard mode.
Comment 4 Karel Zak 2005-09-07 05:37:42 EDT
Any progess with FC4?
Comment 5 Karel Zak 2005-10-20 08:42:22 EDT
Since there are insufficient details provided in this report for
us to investigate the issue further, and we have not received the
feedback we requested, we will assume the problem was not
reproduceable or has been fixed in a later update for this product.

Users who have experienced this problem are encouraged to upgrade
to the latest update release, and if this issue is still
reproduceable, please REOPEN this big report.

Note You need to log in before you can comment on or make changes to this bug.