Bug 1419844 - The atomic-openshifit-node and openvswitch images weren't upgraded on master hosts
Summary: The atomic-openshifit-node and openvswitch images weren't upgraded on master ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Jan Chaloupka
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 08:48 UTC by Anping Li
Modified: 2017-07-24 14:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-13 12:02:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0903 0 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-04-12 22:45:42 UTC

Description Anping Li 2017-02-07 08:48:45 UTC
Description of problem:
When run upgrade_control_plane.yml on atomic hosts, the atomic-openshift-node and openvswitch image weren't upgraded.

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.5.4-1.git.0.034b615.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.  install OCP 3.4 HA Env on Atomic Host
2.  run v3_5/upgrade_control_plane.yml
3.  check pods status
4.  run v3_5/upgrade_node.yml
5.  check pods status

Actual results:
The atomic-openshifit-node and openvswitch use v3.4 images on master hosts

Expected results:
The atomic-openshifit-node and openvswitch should be upgraded by  upgrade_control_plane.yml

Additional info:

Comment 2 Scott Dodson 2017-02-07 16:18:54 UTC
Jan, Did we somehow not include containerized node upgrades in the work you did to include node upgrades on masters during control plane?

Comment 3 Anping Li 2017-02-08 06:28:36 UTC
Scott, Jan the issue also exist with RPM installation. I think the reason is that only partial PR were merged into atomic-openshift-utils-3.5.4-1.git.0.034b615.el7.noarch

Comment 4 Anping Li 2017-02-10 07:09:16 UTC
Try with atomic-openshift-utils-3.5.6-1.git.0.5e6099d.el7.noarch, all PR was merged into it. But the issue still exist.

Comment 5 Jan Chaloupka 2017-02-13 14:04:28 UTC
Anping,

that could be related to the inventory file. Can you share its content? Currently, only masters that are nodes at the same time are upgraded:

- name: Drain and upgrade master nodes
  hosts: oo_masters_to_config:&oo_nodes_to_upgrade

Comment 8 Anping Li 2017-02-15 01:59:12 UTC
For RPM installation, The atomic-openshift-node wasn't restarted in master host. You can check the pid by 'systemctl status atomic-openshift-node'
For containerized installation, The atomic-openshift-node is still use v3.4. you can use 'docker ps' command.

Comment 10 Jan Chaloupka 2017-02-16 12:47:35 UTC
Resolved by https://github.com/openshift/openshift-ansible/pull/3380

Comment 12 Jan Chaloupka 2017-02-16 13:26:15 UTC
Merged. Anping Li, can you verify?

Comment 13 Anping Li 2017-02-17 11:47:15 UTC
Jan, the fix works. you can build a puddle for further more testing.

Comment 14 Jan Chaloupka 2017-02-17 13:23:18 UTC
Scott, is building a puddle something you can do?

Comment 15 Scott Dodson 2017-02-17 13:30:51 UTC
I have, but for some reason the installer isn't making it into the errata puddle. It's in the non errata puddle though. I'll sort this out today.

Comment 18 Anping Li 2017-02-22 07:02:04 UTC
The nodes was upgraded by upgrade_control_plane.yml, so move bug to verified.


Note You need to log in before you can comment on or make changes to this bug.