Bug 1419847 - Upgrade failed when v1beta3 in master-config.yaml [NEEDINFO]
Summary: Upgrade failed when v1beta3 in master-config.yaml
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 08:53 UTC by Anping Li
Modified: 2017-06-08 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-08 20:26:00 UTC
Target Upstream Version:
sdodson: needinfo? (mbarrett)


Attachments (Terms of Use)

Description Anping Li 2017-02-07 08:53:14 UTC
Description of problem:
The playbook v3_0_to_v3_1/upgrade.yml failed to start atomic-openshift-master due to v1beta3 is in /etc/origin/master/master-config.yaml.

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.0.94-1.git.0.67a822a.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.  install OCP 3.0
2.  upgrade OCP 3.0 to OCP 3.1
   ansible-playbook -i hosts /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_0_to_v3_1/upgrade.yml.

Actual results:
2.     TASK: [Restart master service] ************************************************
    failed: [10.14.6.151] => {"failed": true}
    msg: Job for atomic-openshift-master.service failed because the control process exited with error code. See "systemctl status atomic-openshift-master.service" and "journalctl -xe" for details.
     
     
    FATAL: all hosts have already failed -- aborting
     
    PLAY RECAP ********************************************************************
               to retry, use: --limit @/root/upgrade.retry
     
    10.14.6.151                : ok=104  changed=17   unreachable=0    failed=1  
    localhost                  : ok=18   changed=0    unreachable=0    failed=0  
     
           
    [root@openshift-151 ~]# journalctl -xe
    -- 
    -- Unit atomic-openshift-master.service has begun starting up.
    Feb 07 00:38:08 openshift-151.lab.sjc.redhat.com atomic-openshift-master[2328]: W0207 00:38:08.467035    2328 start_master.go:269] assetConfig.loggingPublicURL: invalid value '', Details: required to view aggregated container logs in the
    Feb 07 00:38:08 openshift-151.lab.sjc.redhat.com atomic-openshift-master[2328]: W0207 00:38:08.467181    2328 start_master.go:269] assetConfig.metricsPublicURL: invalid value '', Details: required to view cluster metrics in the console
    Feb 07 00:38:08 openshift-151.lab.sjc.redhat.com atomic-openshift-master[2328]: Invalid MasterConfig /etc/origin/master/master-config.yaml
    Feb 07 00:38:08 openshift-151.lab.sjc.redhat.com atomic-openshift-master[2328]: etcdStorageConfig.kubernetesStorageVersion: unsupported value 'v1beta3', Details: supported values: v1
    Feb 07 00:38:08 openshift-151.lab.sjc.redhat.com atomic-openshift-master[2328]: etcdStorageConfig.openShiftStorageVersion: unsupported value 'v1beta3', Details: supported values: v1
    Feb 07 00:38:08 openshift-151.lab.sjc.redhat.com systemd[1]: atomic-openshift-master.service: main process exited, code=exited, status=255/n/a
    Feb 07 00:38:08 openshift-151.lab.sjc.redhat.com systemd[1]: atomic-openshift-master.service: main process exited, code=exited, status=255/n/a
    Feb 07 00:38:08 openshift-151.lab.sjc.redhat.com systemd[1]: Failed to start Atomic OpenShift Master.
    -- Subject: Unit atomic-openshift-master.service has failed

Expected results:
The upgrade should rename v1beta3 to v1 during upgrade.

Additional info:
Workaound: Modify v1beta3 to v1 mannuly before run upgrade playbook.


Note You need to log in before you can comment on or make changes to this bug.