Bug 1419852 - [geo-rep]: Any value is allowed to set for changelog-log-level
Summary: [geo-rep]: Any value is allowed to set for changelog-log-level
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Sunny Kumar
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 08:59 UTC by Rahul Hinduja
Modified: 2019-11-21 10:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-21 10:08:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rahul Hinduja 2017-02-07 08:59:09 UTC
Description of problem:
=======================

Changelog-log-level is an config option to set the log level for changelog to one of the following: 

CRITICAL, ERROR, WARNING, INFO, DEBUG, TRACE

So the cli should valid the input and fail if it is anything else. But it is allowed to set any junk value as follows:

[root@dhcp42-7 vol0]# gluster volume geo-replication vol0 10.70.43.249::vol1 config changelog-log-level test
geo-replication config updated successfully
[root@dhcp42-7 vol0]# gluster volume geo-replication vol0 10.70.43.249::vol1 config changelog-log-level
test
[root@dhcp42-7 vol0]# gluster volume geo-replication vol0 10.70.43.249::vol1 config changelog-log-level zyzshajdhjsd
geo-replication config updated successfully
[root@dhcp42-7 vol0]# 
[root@dhcp42-7 vol0]# 
[root@dhcp42-7 vol0]# gluster volume geo-replication vol0 10.70.43.249::vol1 config changelog-log-level
zyzshajdhjsd
[root@dhcp42-7 vol0]# 



Version-Release number of selected component (if applicable):
=============================================================

glusterfs-geo-replication-3.8.4-13.el7rhgs.x86_64


How reproducible:
=================

Always


Steps to Reproduce:
===================
1. Set some value using

gluster volume geo-replication vol0 10.70.43.249::vol1 config changelog-log-level <value>

Comment 4 Aravinda VK 2018-02-06 08:08:35 UTC
Geo-replication support added to Glusterd2 project, which will be available with Gluster upstream 4.0 and 4.1 releases. 

Most of the issues already fixed with issue https://github.com/gluster/glusterd2/issues/271 and remaining fixes are noted in issue https://github.com/gluster/glusterd2/issues/557

We can close these issues since we are not planning any fixes for 3.x series.

Comment 6 Aravinda VK 2018-11-19 07:40:27 UTC
Fix available upstream: https://review.gluster.org/#/c/glusterfs/+/18257/

Comment 7 Sahina Bose 2019-11-21 08:24:01 UTC
Fix referenced is merged. Should this be moved to ON_QA for verification?

Comment 8 Sunny Kumar 2019-11-21 09:37:30 UTC
I think it is already verified.

Kshithij, can you confirm so that we can close this bz.

Comment 10 Sunny Kumar 2019-11-21 10:08:58 UTC
Thanks Kshithij for your input.

The patch mentioned in comment #6 fixed this bug.


Note You need to log in before you can comment on or make changes to this bug.