Bug 1419854 - vioinput: Driver is dropping rapid input events
Summary: vioinput: Driver is dropping rapid input events
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ladi Prosek
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 09:01 UTC by Ladi Prosek
Modified: 2017-08-01 12:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 12:55:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2341 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2017-08-01 16:52:38 UTC

Description Ladi Prosek 2017-02-07 09:01:19 UTC
Description of problem:
When input events come to quickly, the driver may not be able to process all of them and they are dropped. This affects automated key presses generated by client software, for instance Ctrl+Alt+Del, which may consist of up to 6 events (Ctrl down, Alt down, Del down, Del up, Alt up, Ctrl up).

Version-Release number of selected component (if applicable):
virtio-win-131

How reproducible:
100%

Steps to Reproduce:
1. Start a Windows VM with -device virtio-keyboard-pci and -vnc
2. Connect to it using Remote Viewer
3. In Remote Viewer, go to the Send Key menu and select Ctrl+Alt+Del

Actual results:
Ctrl+Alt+Del is not received by the guest

Expected results:
Ctrl+Alt+Del is received

Additional info:
Reported and debugged by Peng Hao <peng.hao2@zte.com.cn>

Comment 1 Ladi Prosek 2017-02-07 09:02:45 UTC
A patch was submitted by Peng Hao:
https://github.com/YanVugenfirer/kvm-guest-drivers-windows/pull/93

Comment 2 Yu Wang 2017-02-08 07:21:51 UTC
Reproduce this issue on QE side w/ build 131 on win10-64.
Steps as comment#0

Thanks
Yu Wang

Comment 4 Yu Wang 2017-02-15 06:33:18 UTC
Hi 

Verify this bug on build 132 (win10-64 guest), steps as comment#0, can use "Ctrl+Alt+Del" successfully

Thanks
Yu Wang

Comment 5 lijin 2017-02-15 06:35:53 UTC
change status to verified according to comment#4

Comment 8 errata-xmlrpc 2017-08-01 12:55:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2341


Note You need to log in before you can comment on or make changes to this bug.