Bug 1419882 - Can't save deployment configuration (environment files) in the GUI in OSP11
Summary: Can't save deployment configuration (environment files) in the GUI in OSP11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Honza Pokorny
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 10:21 UTC by Udi
Modified: 2017-05-17 19:57 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-ui-3.1.0-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:57:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 451987 None None None 2017-04-05 14:04:18 UTC
OpenStack gerrit 455462 None None None 2017-04-11 15:43:47 UTC
Launchpad 1674789 None None None 2017-03-21 18:42:21 UTC

Description Udi 2017-02-07 10:21:51 UTC
Description of problem:
When clicking "Save Changes" in the configuration dialog, you get a success message but the dialog doesn't close and the changes you made are not saved. You have to press "Cancel" to close the dialog and there is no way to enable environment files. No errors are seen in the console.

This is currently a blocker for the testing.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-2.0.1-0.20170126144317.f3bd97e.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Click on "Edit Configuration" to open the deployment configuration dialog
2. Enable some environment files, for example storage
3. Save changes


Actual results:
The dialog doesn't close 


Expected results:
Changes should be saved, the dialog should be closed.

Comment 3 Honza Pokorny 2017-03-10 18:37:28 UTC
Using the 11.0-20170308.1.el7ost puddle, and latest upstream, I cannot reproduce this issue.  Selecting the storage environment, and clicking "save" shows a success notification.  The selection is properly persistent between page reloads.

Note that I don't believe the dialog is to close upon successful save.  You are and should be able to continue editing the properties of the plan once you save.

There are errors in the javascript console.

Are there any errors in your console?

Comment 4 Udi 2017-03-16 14:10:10 UTC
This bug still recreates downstream with the latest puddle (2017-03-15) and it's a blocker for the automation. There are no errors in the console.

Comment 6 Honza Pokorny 2017-03-20 16:39:18 UTC
I propose to solve this by adding another button to the dialog.  We will then have two buttons for saving: "Save" and "Save and close".

Comment 7 Jason E. Rist 2017-03-20 16:54:29 UTC
Seconded

Comment 8 Ola Pavlenko 2017-03-26 16:09:22 UTC
upstream fix proposed - waiting for reviews

Comment 10 Mike Burns 2017-03-30 14:52:08 UTC
while in review, this should be on_dev

Comment 11 Jason E. Rist 2017-04-05 13:37:48 UTC
https://review.openstack.org/#/c/451987/ merged

Comment 13 Ola Pavlenko 2017-04-09 06:53:28 UTC
"Save and Close" button on parameters tab is missing
openstack-tripleo-ui-3.1.0-8.el7ost.noarch

Comment 14 Honza Pokorny 2017-04-11 11:09:45 UTC
https://review.openstack.org/#/c/455462/ merged

Comment 16 Udi 2017-04-25 12:36:41 UTC
Verified in 2017-04-24.2

Comment 17 errata-xmlrpc 2017-05-17 19:57:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.