Bug 1419885 - Selected Snapshot does not get deleted on vm with suspended state
Summary: Selected Snapshot does not get deleted on vm with suspended state
Keywords:
Status: CLOSED DUPLICATE of bug 1421951
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Adam Grare
QA Contact: Dave Johnson
URL:
Whiteboard: snapshot
: 1422411 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 10:29 UTC by Aziza Karol
Modified: 2017-12-05 15:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-01 18:48:26 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Aziza Karol 2017-02-07 10:29:16 UTC
Description of problem:


Version-Release number of selected component (if applicable):
5.7.1.0.20170124142149_8a5f4d5 

How reproducible:
100%

Steps to Reproduce:
1.Navigate to  compute->infrastructure->virtual machines 
2.Select a vm with suspended state
3.create a snapshot. 
4.Then select and delete the selected snapshot

Actual results:
snapshot does not get deleted on vm with suspended state and error is thrown in evm.log

Expected results:


Additional info:
evm.log
[----] I, [2017-02-07T05:01:32.109632 #6549:1167140]  INFO -- : MIQ(MiqQueue#deliver) Message id: [1388454], Delivering...
[----] E, [2017-02-07T05:01:32.166314 #6549:1167140] ERROR -- : MIQ(MiqQueue#deliver) Message id: [1388454], Error: [Requested VM snapshot not found, unable to remove snapshot]
[----] E, [2017-02-07T05:01:32.167586 #6549:1167140] ERROR -- : [RuntimeError]: Requested VM snapshot not found, unable to remove snapshot  Method:[rescue in deliver]
[----] E, [2017-02-07T05:01:32.168160 #6549:1167140] ERROR -- : /var/www/miq/vmdb/app/models/vm_or_template/operations/snapshot.rb:44:in `raw_remove_snapshot'
/var/www/miq/vmdb/app/models/vm_or_template/operations/snapshot.rb:66:in `remove_snapshot'
/var/www/miq/vmdb/app/models/miq_queue.rb:347:in `block in deliver'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:91:in `block in timeout'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `block in catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:106:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:343:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:152:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:334:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:153:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:128:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:21:in `start_worker'
/var/www/miq/vmdb/app/models/miq_worker.rb:343:in `block in start'
/opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
/opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
/var/www/miq/vmdb/app/models/miq_worker.rb:341:in `start'
/var/www/miq/vmdb/app/models/miq_worker.rb:270:in `start_worker'
/var/www/miq/vmdb/app/models/miq_worker.rb:150:in `block in sync_workers'
/var/www/miq/vmdb/app/models/miq_worker.rb:150:in `times'
/var/www/miq/vmdb/app/models/miq_worker.rb:150:in `sync_workers'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:52:in `block in sync_workers'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `each'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `sync_workers'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:22:in `monitor_workers'
/var/www/miq/vmdb/app/models/miq_server.rb:346:in `block in monitor'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
/var/www/miq/vmdb/app/models/miq_server.rb:346:in `monitor'
/var/www/miq/vmdb/app/models/miq_server.rb:368:in `block (2 levels) in monitor_loop'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
/var/www/miq/vmdb/app/models/miq_server.rb:368:in `block in monitor_loop'
/var/www/miq/vmdb/app/models/miq_server.rb:367:in `loop'
/var/www/miq/vmdb/app/models/miq_server.rb:367:in `monitor_loop'
/var/www/miq/vmdb/app/models/miq_server.rb:250:in `start'
/var/www/miq/vmdb/lib/workers/evm_server.rb:65:in `start'
/var/www/miq/vmdb/lib/workers/evm_server.rb:92:in `start'
/var/www/miq/vmdb/lib/workers/bin/evm_server.rb:4:in `<main>'
[----] I, [2017-02-07T05:01:32.168612 #6549:1167140]  INFO -- : MIQ(MiqQueue#delivered) Message id: [1388454], State: [error], Delivered in [0.058991428] seconds
[----] I, [2017-02-07T05:01:32.171449 #6549:1167140]  INFO -- : MIQ(MiqQueue#m_callback) Message id: [1388454], Invoking Callback with args: ["Finished", "error", "Requested VM snapshot not found, unable to remove snapshot", "nil"]

Comment 2 Adam Grare 2017-02-15 13:54:51 UTC
*** Bug 1422411 has been marked as a duplicate of this bug. ***

Comment 3 Adam Grare 2017-03-01 18:48:26 UTC
This looks to stem from the same issue as https://bugzilla.redhat.com/show_bug.cgi?id=1421951 where the snapshot_id wasn't being passed in.

*** This bug has been marked as a duplicate of bug 1421951 ***


Note You need to log in before you can comment on or make changes to this bug.