Bug 1419887 - Hide/Show advanced config for invalid automatic hpa settings has different Create button status
Summary: Hide/Show advanced config for invalid automatic hpa settings has different Cr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 10:33 UTC by XiaochuanWang
Modified: 2017-07-24 14:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On the add to project page, if you enter invalid setting for some advanced options, then hide the advanced options, you could submit the form with invalid values. This could cause errors creating some resources like horizontal pod autoscalers. The web console was changed to correctly validate these fields so that you can't submit the form with invalid values.
Clone Of:
Environment:
Last Closed: 2017-04-12 19:12:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot for step 5 (73.62 KB, image/png)
2017-02-07 10:33 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description XiaochuanWang 2017-02-07 10:33:08 UTC
Created attachment 1248365 [details]
screenshot for step 5

Description of problem:
Create an app from image, input app name and git repo url, show advanced options, select "Automatic" for scaling strategy, the "Create" button is disabled, but the button will be enabled when user hide the advanced options with the settings is saved.

Version-Release number of selected component (if applicable):
openshift v3.5.0.17+c55cf2b

How reproducible:
Always

Steps to Reproduce:
1. Click "Add to project" 
2. Select an image and choose a version, input app name and github url.
3. Hit "show advanced options", select "Automatic" for scaling strategy, check the Create button
4. Hide the "show advanced options" and check the Create button.
5. Hit the Create button


Actual results:
3. The button is disabled
4. The button is enabled
5. There is an error message that the HPA is invalid, please see the screenshot

Expected results:
3 and 4 should has same status for Create button


Additional info:

Comment 1 openshift-github-bot 2017-02-08 14:36:57 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/a6ecc112fc52d95466e9c7245e137fcf59778df6
Bug 1419887 - Validate advanced form inputs that are hidden

When advanced options values have errors and a user hides them, still
disable the save button.

Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1419887

Comment 2 XiaochuanWang 2017-02-09 09:01:51 UTC
Found PR https://github.com/openshift/origin-web-console/pull/1228 is merged.
Tested on 3.5.0.18 and it's not reproduced with original steps.
This bug could be verified if status changed to ON_QA

Comment 3 XiaochuanWang 2017-02-13 01:33:07 UTC
Verified on 3.5.0.18 with original steps

Comment 5 errata-xmlrpc 2017-04-12 19:12:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.